SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Thread: layout problems

  1. #1
    SitePoint Member
    Join Date
    Dec 2003
    Location
    nyc
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question layout problems

    I am doing a site redesign and am having major trouble with what I am guessing is a minor problem.

    First look here:

    http://www.soundofpeace.com/newdesign/untitled1987.html

    This has the horizontal layout I want (specifically the relationship between the content and the navigation bar).

    But when I add content to (essentaily) the same page, see here:

    http://www.soundofpeace.com/newdesign/filmmaker.html

    the horizontal layout changes by a few pixels. Any advice? I can't for the life of me figure it out. Thanks!

  2. #2
    SitePoint Member
    Join Date
    Dec 2003
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    To be honest, everything is okay for me. I can't find even the smallest pixel in difference between the two pages. What browser are you using?
    For me, everything looks fine in IE6.0.

    However, the vertical space does extend to the bottom of the screen, whereas based on the content this does not seem to be needed. But since your question was related to the horizontal direction, I'd have to say there is nothing wrong with your layout, at least not for IE6.0.

  3. #3
    SitePoint Member
    Join Date
    Dec 2003
    Location
    nyc
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I see the problem with both Safari and IE on OS X 10.3. For me the dotted vertical border (that separates the content from the navigation) moves a few pixels between the pages. I am aware the extra vertical space is not needed, but it's there to represent additional content. Also, I should mention, I strongly believe that there is something about the content in the gray box that creates this problem. I am suspicious that it has something to do with the <br> tags in the content, but I'm not sure why. Any thoughts based on the code? Thanks.

  4. #4
    SitePoint Enthusiast
    Join Date
    Oct 2003
    Location
    Orlando
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't see an issue with the dotted vertical border between the sidebar and the content but I do see an issue with the right border not displaying next to the links. You have the sidebar td defined as 180px, yet the navcontainer is nested in the td and is 190px. The problem comes in when you display the a tags as block and also specify the width to be 190px. Dropping this value (say to 180..your td width) displays the border once again.

    BTW...the problem was seen on both IE6 and Firebird 0.7 in XP.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •