SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Thread: Linux Problems

  1. #1
    SitePoint Wizard
    Join Date
    Apr 2000
    Posts
    1,483
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi all,

    This morning I put togethor a computer made of spare parts for me to install Linux on - primarily as a learning machine. Spec is: AMD K6-233, QDI Titanium 1B+ mobo with 430TX chipset, Fujitsu 2.5GB hard drive, 64Mb SDRAM, 3Com 3C905C NIC

    I installed SuSe 6 just fine - no problems at all. Everything appeared to work. I had it on my network, using the version of Apache that had been installed as standard with SuSe.
    But then I wanted to install MySQL, so I downloaded the latest RPM from http://mysql.com. Followed the instructions, which was basically to type this:
    rpm -i --nodeps MySQL-3.23.28-1.i386.rpm
    That command hangs the machine - nothing more can be done locally, through ftp or telnet. At the same time, the hard drive spins up loudly, then slows down again. I'm pretty sure the hard drive is working perfectly as it just came out of a Windows 2000 server.
    There are some discussion lists/boards with people reporting similar problems here: http://www.google.com/search?q=linux...f&start=0&sa=N but none of them really give me a solution, just confirm that I'm not the only one with this problem.

    Would upgrading to SuSe/RedHat 7 fix it?
    Please Please help if you can I'm getting desperate now.
    Anything is much appreciated

    James.

  2. #2
    SitePoint Wizard
    Join Date
    Jul 1999
    Location
    Chicago
    Posts
    2,629
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Get the source tarball from mysql.com and see if it works. Generally if you have problems installing an RPM they are solved with the source.

    It sounds like maybe there was a bug in the RPM installer software, or maybe the --nodeps messed up since IIRC, SuSe is not an RPM-based distro. Keep us updated...

  3. #3
    SitePoint Enthusiast
    Join Date
    Jun 2000
    Location
    Apple Valley, MN
    Posts
    96
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well...I gotta admit: qslack knows alot about Linux.
    Fiber
    fiber@liquid2k.com
    73218345
    "Prepare yourself, it's da human beatbox"

  4. #4
    SitePoint Wizard
    Join Date
    Apr 2000
    Posts
    1,483
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for your help qslack, although I don't think the RPM is the problem - this morning I downloaded Perl 5.6 source to install. The machine locked up while I was ftping the files through to the hard drive.
    So I'm pretty sure the problem is a compatibility problem between Linux and my Fujitsu hard drive.
    Later on I'm going to try and obtain another drive to see if that works.

  5. #5
    SitePoint Wizard
    Join Date
    Apr 2000
    Posts
    1,483
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Managed to fix the crashes by finding a replacement hard drive - its smaller than the old one but works
    Thanks for your help anyway


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •