SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Enthusiast
    Join Date
    Feb 2003
    Location
    USA
    Posts
    64
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CSS (I think) Problems

    I have a couple forms on this page. They should have white backgrounds with black borders like the regular text. They do have look right in IE, but not in Mozilla. I've triple checked all the code. Any ideas why my forms aren't acceptting the css background and border in Mozzila? Thanks!
    --David Reagan
    DavidReagan.net

  2. #2
    SitePoint Enthusiast Debs's Avatar
    Join Date
    Aug 2003
    Location
    new york
    Posts
    96
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You have this:
    <input type="text" name="user" value="enter email address" size="20">

    try this:
    <input type="text" name="user" value="enter email address" size="20" class="form">

  3. #3
    SitePoint Enthusiast
    Join Date
    Feb 2003
    Location
    USA
    Posts
    64
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Ok

    Well, that changed the text boxes, but that wasn't what I needed.

    Here are a couple screenshots.

    pkzine1.jpg is in Mozilla, and pkzine2.jpg is in IE and is how it is supposed to look.
    Attached Images Attached Images
    --David Reagan
    DavidReagan.net

  4. #4
    Ceci n'est pas Zoef Zoef's Avatar
    Join Date
    Nov 2002
    Location
    Malta
    Posts
    1,111
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Could you post the ulr for that particular page?

    Rik

    Edit:

    Oops... missed it, noticed it now
    English tea - Italian coffee - Maltese wine - Belgian beer - French Cognac

  5. #5
    Ceci n'est pas Zoef Zoef's Avatar
    Join Date
    Nov 2002
    Location
    Malta
    Posts
    1,111
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Seems to me all you need to do is put
    Code:
    form {background-color:#fff; /* and other styles you wish for */ }
    in your CSS.

    Rik
    English tea - Italian coffee - Maltese wine - Belgian beer - French Cognac

  6. #6
    SitePoint Enthusiast
    Join Date
    Feb 2003
    Location
    USA
    Posts
    64
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hmm... Well, I tried what you suggested, and it looks horrible... You can go look at it to see what I mean.
    --David Reagan
    DavidReagan.net

  7. #7
    SitePoint Enthusiast
    Join Date
    Feb 2003
    Location
    USA
    Posts
    64
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes! I figured it out. I needed a /form tag at the end..... Then delete a couple p's, and it works! Thanks!
    --David Reagan
    DavidReagan.net


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •