SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Jun 2002
    Posts
    51
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry Please Help: Cross platform CSS & H1 Tag alignment

    ok guys i really need your help.

    *** I have no windows machine to test this on ***

    i thought i had this site for windows and mac's looking identical.

    i am on a mac running OS X and Safari and everything looks perfect

    friends i have asked on PC's running Xp and Internet Explorer 6 have said it looks perfect, but i got on 2 different XP boxes running IE 6 and the spacing was all off..

    i am trying to use the upper div to contain a H1 tag (for google purposes) but its causing problems


    here is a sample file with internal css


    can anyone help me figure this out please?

    *** I have no windows machine to test on ***

  2. #2
    SitePoint Addict BenANFA's Avatar
    Join Date
    Apr 2003
    Location
    Bath, UK
    Posts
    353
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try changing your h1 style from
    Code:
    h1
    {
    	position: relative;
    	top: -6px;
    	font: bold 12px Arial, Tahoma, Verdana, Helvetica, sans-serif;
    }
    to
    Code:
    h1
    {
    	margin: 0px;
    	font: bold 12px Arial, Tahoma, Verdana, Helvetica, sans-serif;
    }

  3. #3
    SitePoint Addict
    Join Date
    Dec 2002
    Posts
    386
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    first off, the H1 doesn't need to be in a div, just apply the styles to the h1 directly, or put a class in the h1

    next try setting the margin and padding of the h1 before trying to position it, and the top -6px in the relatively positioned h1 is just asking for issues...
    just simplify I think


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •