SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Sep 2003
    Location
    Panama
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CSS not working in Netscape 7.0

    Hi there.

    I am working on a new site for a non-profit called the New Ground Center. Right now it is being hosted at:

    https://earthtecinc.com/newground

    The site looks great on my browser - the only main problem being that as I resize the browser the no-repeat background image (the site's title) gets eaten up by the divs.

    However when I go to check things in Netscape 7.0, things get really screwy. Suddenly none of the div attributes are being read - not width, not background color, not borders. I went and looked over the CSS code but can't seem to locate the problem - Netscape 7.0 is supposedly compatible with CSS1, correct?

    You can have a look at the css code by going to
    https://www.earthtecinc.com/newground/ngindex.css

    I also heard from a friend that the div blocks are overlapping in IE5.0 but she didn't get much mroe specific than that. Any help would be greatly appreciated.

    Thanks. Susan

  2. #2
    SitePoint Addict
    Join Date
    Sep 2003
    Location
    Europe
    Posts
    222
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    http://validator.w3.org:8001/check?u...bose=1&fussy=1
    And in your css you have:
    Code:
    h5 {
    h6 {margin-top:20px...
    You need to close the h5 rule.

    Fix those things and I think Netscape7 will play nice.

  3. #3
    SitePoint Member
    Join Date
    Sep 2003
    Location
    Panama
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, that seemed to work!
    Funny how it is always the little things.

    Any ideas of how one might deal with the no-repeat background image getting eaten by the other blocks?

  4. #4
    SitePoint Addict
    Join Date
    Sep 2003
    Location
    Europe
    Posts
    222
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't really get what you're asking here... Maybe a positioning thing?

  5. #5
    SitePoint Enthusiast DiDoKa's Avatar
    Join Date
    Oct 2003
    Location
    MA
    Posts
    54
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by earthsusan
    Thanks, that seemed to work!
    Funny how it is always the little things.

    Any ideas of how one might deal with the no-repeat background image getting eaten by the other blocks?

    yep, make a treaty with yourself and decide at which screen size the image will be eaten. It is a quite common thing when using backgrounds and i don't really give a darn about it anymore, i mean, who is surfing arround with a screen as small ans my finger? As long as the background is still visable in a fairly small screensize (one you think is realistic) it is okay.

  6. #6
    SitePoint Member
    Join Date
    Sep 2003
    Location
    Panama
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    in my treaty i have decided that after decreasing more than 1/2 of the normal browser size it will be fine to have the background image eaten. right now it happens at about 80% - does this mean i need to make the content boxes narrower, move the background image closer to the edge of the browser, or is there a way to keep them from sneaking over to the left?
    thanks!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •