SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Aug 2003
    Location
    England
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Table within Table Alignment problem - Basic

    Hi,

    I've been doing a lot of tableless css design recently, but after problems trying to create my design to work in all browsers, i decided to do it in el olde html.

    So, i've been making the basis of it, with just random colours and boxes, with no proper images yet, when i come accross a problem i just cant remember how to solve.

    On the left hand side (and the right infact) I have columns for things like a shout box, link of the week etc. I want to put in these columns little tables, as i have shown on the page. However, because this is connected to the middle table, which is large, all these little tables get centered into the middle of this really big row.

    I first thought this was a verticle align problem. But i guess i just need a colspan or a rowspan in one of the columns to sort this out. However i cant work out which one i put it in, and what i put in.

    I know this is a pritty basic question, but i havent done html for so long i've forgotten how to do it :S.

    Thanks for any help,

    http://www.kil-clan.co.uk/Design

    (Excuse website hosting, i think its running slow today)

  2. #2
    SitePoint Enthusiast hutchysk8er's Avatar
    Join Date
    Apr 2003
    Location
    Scotland
    Posts
    61
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i take it you want the mini tables in the left and right rows at the top yeah? well if you do change the <td> tag for the right 1 to
    Code:
    <td class="rightbit" valign="top">
    and the td for the left 1 to
    Code:
     <td class="leftbit" valign="top">
    Hutchy

  3. #3
    SitePoint Member
    Join Date
    Aug 2003
    Location
    England
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ahhh, thankyou thankyou thankyou
    I was putting the valign on the smaller tables inside those TDs, not on the actual column. Thanks for the help !

  4. #4
    SitePoint Enthusiast hutchysk8er's Avatar
    Join Date
    Apr 2003
    Location
    Scotland
    Posts
    61
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Welcome. lol, i copy pasted your code in2 dreamweaver 2 check if wot i thot was rite, an i made the same mistake u did.
    Hutchy


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •