SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Oct 2003
    Location
    home
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    File upload timeouts

    I am having trouble getting files larger than 1MB uploaded. I went to the php.ini file on my server and changed the "upload_max_filesize" to 20M and I also tried changing it to 20000000. I don't need that much set here, but just wanted to make sure there is plenty of room for success. Nevertheless, neither setting has solved the problem.

    There is no "max" setting on the upload page itself, so I don't know why I'm having a problem.

    Can anyone give me any other suggestions to fix this?

    Thanks in advance!

  2. #2
    SitePoint Evangelist Daijoubu's Avatar
    Join Date
    Oct 2002
    Location
    Canada QC
    Posts
    454
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    max_input_time in php.ini
    And apache own timeout...

    May also want to increase memory_limit

  3. #3
    SitePoint Member
    Join Date
    Oct 2003
    Location
    home
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Daijoubu
    max_input_time in php.ini
    And apache own timeout...

    May also want to increase memory_limit


    Thanks, Daijoubu!

    That took care of the problem. I REALLY!! appreciate that help!

  4. #4
    Non-Member
    Join Date
    Jan 2003
    Posts
    5,748
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    "max" setting on the upload page itself,
    You should have something in there in your FORM by rights ? ...

    Just to be sure that you've taken this extra precaution as I see it...

    PHP Code:
    ...
    .
    .
    <
    input type='hidden' name='MAX_FILE_SIZE' size='524288' />
    .
    .
    ... 
    For example [0.5Mb] ? If I remember that's the way to do it. But if your server is time out then doubtful you'll have the same problem no matter what amount you try to upload


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •