SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Guru mdumka's Avatar
    Join Date
    Jul 2003
    Location
    True North
    Posts
    642
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Javascript Problem in Netscape

    I am using Javascript sliding menus and Div layers with FLASH and everything was working fine in Dreamweaver (IE) but when I went to view in Netscape, there is a white border that displays all the way around the viewing are that scres up my menus because they are placed in absolute positions.

    Can anybody help please?

    I am also programming in ColdFusion if that matters.

    my website is www.computercablesandmore.com

  2. #2
    SitePoint Addict
    Join Date
    Dec 2002
    Posts
    386
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It is not so much a js problem (although there are some on your site) but a standards problem. If you design your site with code specific to one browser you shouldn't be surprised if it fails to work in all the others.
    your css is not valid, your html is not valid and is using old buggy methods, you have a transparant flash movie, but have left the switch to make it transparent in safari and mozilla/netscape out...

    for your immediate problem try setting the margin and padding of your body to 0

  3. #3
    SitePoint Guru mdumka's Avatar
    Join Date
    Jul 2003
    Location
    True North
    Posts
    642
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks pissant, I could not find the padding code but i used margin width and margin height and it seemed to fix the problem with the border.

    Now how do I fix that problem with the transparent flash file?

    your help is awsome.

    Mike

  4. #4
    SitePoint Addict
    Join Date
    Dec 2002
    Posts
    386
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    basically add this to the embed tag

    wmode="transparent"

    this should enable transparency for ie5.1-5.2/macosX, netscape 7+ mozilla 1.3+ and also safari... but I haven't tested safari yet


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •