SitePoint Sponsor

User Tag List

Results 1 to 10 of 10
  1. #1
    100% Windoze-free earther's Avatar
    Join Date
    Feb 2003
    Location
    Linuxland
    Posts
    2,788
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Two annoying browser quirks

    I have noticed some strange browser quirks. My 1px borders disappear and reappear in Firebird/Mozilla/Opera as the font size is changed. And justified italics cause div border alignments to break a few pixels in IE. Grrrrrr. I suspect it has to do with the fact that I use percentages instead of pixels. Anybody else noticed these two annoying bugs?

  2. #2
    100% Windoze-free earther's Avatar
    Join Date
    Feb 2003
    Location
    Linuxland
    Posts
    2,788
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    *bump*

    This isn't happening to anyone else? I'd certainly like to know how to work around these bugs . . .

  3. #3
    SitePoint Addict hurricane.uk's Avatar
    Join Date
    May 2003
    Location
    Liverpool
    Posts
    361
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Link?

  4. #4
    ☆★☆★ silver trophy vgarcia's Avatar
    Join Date
    Jan 2002
    Location
    in transition
    Posts
    21,235
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    If you show some code we'll be able to help more

  5. #5
    100% Windoze-free earther's Avatar
    Join Date
    Feb 2003
    Location
    Linuxland
    Posts
    2,788
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sorry for being so vague but I thought this was a generic problem since it also happens on the www.cosmiccradle.com site that I did a while back.

    Anyhoo . . . here is an example that shows both of the glitches:

    http://www.saynotogmos.org/redo/biodemocracy_news.html

    In IE, the justified italic text causes the RH border to break by about 2px. If I remove the <em> it snaps back into place. (http://www.saynotogmos.org/redo/biodemocracy_news.htm)

    In Opera/Firebird, reducing the size of the font causes some of the borders to disappear, different borders at different font sizes. Also the text justification breaks down at any font size other than 100%.

    Style sheet is here: http://www.saynotogmos.org/redo/new.css

    Is this enough info? Thanks for looking.

  6. #6
    SitePoint Evangelist ucahg's Avatar
    Join Date
    Apr 2001
    Location
    Sarnia, Ontario, Canada
    Posts
    434
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Some methods of CSS positioning (I think float in particular, or negative margins) seem to cause this problem. What I did when it occured was delete the code that seemed to cause the problem (that is, the code I added before it began to occur). In my case it was a form. I then rewrote it a little differently and the problem was solved. I'm being very vague and am not confident in this solution, because it seemed to work for me, although I don't know exactly what it was that fixed it.
    Love it? Hate it? Helpful? Useless?
    Use the rate button to let me know what you think of my post!

  7. #7
    100% Windoze-free earther's Avatar
    Join Date
    Feb 2003
    Location
    Linuxland
    Posts
    2,788
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ucahg
    Some methods of CSS positioning (I think float in particular, or negative margins) seem to cause this problem. What I did when it occured was delete the code that seemed to cause the problem (that is, the code I added before it began to occur). In my case it was a form. I then rewrote it a little differently and the problem was solved. I'm being very vague and am not confident in this solution, because it seemed to work for me, although I don't know exactly what it was that fixed it.
    Which problem did you solve . . . the italic/borderbreak one or the justified font one?

  8. #8
    SitePoint Evangelist ucahg's Avatar
    Join Date
    Apr 2001
    Location
    Sarnia, Ontario, Canada
    Posts
    434
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Various inconsistencies with borders and sections disappering and reappearing. It was mostly in IE actually, so it doesn't really apply to your problem.

    But just fiddle with your code, comment out HTML and see if it's still there, comment out CSS and see if the problem is still there, and try to narrow down the problem that way. Then you'll be much further along to fixing it.
    Love it? Hate it? Helpful? Useless?
    Use the rate button to let me know what you think of my post!

  9. #9
    100% Windoze-free earther's Avatar
    Join Date
    Feb 2003
    Location
    Linuxland
    Posts
    2,788
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ucahg
    Various inconsistencies with borders and sections disappering and reappearing. It was mostly in IE actually, so it doesn't really apply to your problem.

    But just fiddle with your code, comment out HTML and see if it's still there, comment out CSS and see if the problem is still there, and try to narrow down the problem that way. Then you'll be much further along to fixing it.
    Interesting discovery . . . the italics breaking the border thing doesn't happen in IE5.5, only IE6. Go figure.

  10. #10
    SitePoint Addict hurricane.uk's Avatar
    Join Date
    May 2003
    Location
    Liverpool
    Posts
    361
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm unable to reproduce your problem in Firebird on this page:

    http://www.saynotogmos.org/redo/biodemocracy_news.html


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •