SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Addict ibeblunt's Avatar
    Join Date
    Jan 2001
    Location
    Jersey City, NJ
    Posts
    312
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Page Looks Fine Locally, But Fails Live

    I've been working on this page for most of the afternoon, and the ONLY problem that I'm having with it is this ONE area. Here's the page:

    http://www.sohh.com/index_1.php

    If you look at the left hand side, you'll see a search area. On either side you'll see bottles of beer. Now, inbetween that is a TD with a image being called, but it won't show LIVE. If you view my source, select all and save it to your HD, it will work.

    The code I have is:

    Code:
    <td
         width="141"
         align="center"
         style="background-color: #000;
              background-image: url("http://www.sohh.com/images/skin/obie_trice/tile_search.gif");
              background-repeat: no-repeat;">
    Any tips will be appreciated...It's been a long day. Hopefully some fresh eyes will see the error of my ways.

    one
    <///////~

    www.sohh.com

  2. #2
    100% Windoze-free earther's Avatar
    Join Date
    Feb 2003
    Location
    Linuxland
    Posts
    2,788
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Why don't you just call it as a regular image instead of a BG image. Seems like making it a BG image just complicates things.

  3. #3
    SitePoint Addict hurricane.uk's Avatar
    Join Date
    May 2003
    Location
    Liverpool
    Posts
    361
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ibeblunt
    url("http://www.sohh.com/images/skin/obie_trice/tile_search.gif")
    That's not what's in your markup, this is:


    Code:
    url("http://www.sohh.com/images/skin/obie_trice/tile_search.gif);
    Notice the absence of the closing " for the background image.

  4. #4
    SitePoint Addict ibeblunt's Avatar
    Join Date
    Jan 2001
    Location
    Jersey City, NJ
    Posts
    312
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by earther
    Why don't you just call it as a regular image instead of a BG image. Seems like making it a BG image just complicates things.
    Because I need the form on top of the image.
    <///////~

    www.sohh.com

  5. #5
    SitePoint Addict ibeblunt's Avatar
    Join Date
    Jan 2001
    Location
    Jersey City, NJ
    Posts
    312
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by hurricane.uk
    That's not what's in your markup, this is:


    Code:
    url("http://www.sohh.com/images/skin/obie_trice/tile_search.gif);
    Notice the absence of the closing " for the background image.
    You sure? When I look at the source I get this:

    Code:
    <td width="141" align="center" style="background-color: #000; background-image: url("http://www.sohh.com/images/skin/obie_trice/tile_search.gif"); background-repeat: no-repeat;"><input type="text" name="query" style="border: 1px solid #000; width: 100px;" />
    						<br /><img width="58" height="5" src="/images/spacer.gif" />
    						<br /><input type="image" src="http://www.sohh.com/images/skin/default/butn_search.gif" width="58" height="18" /></td>
    <///////~

    www.sohh.com

  6. #6
    SitePoint Evangelist ucahg's Avatar
    Join Date
    Apr 2001
    Location
    Sarnia, Ontario, Canada
    Posts
    434
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ibeblunt
    You sure? When I look at the source I get this:

    Code:
    <td width="141" align="center" style="background-color: #000; background-image: url("http://www.sohh.com/images/skin/obie_trice/tile_search.gif"); background-repeat: no-repeat;"><input type="text" name="query" style="border: 1px solid #000; width: 100px;" />
    						<br /><img width="58" height="5" src="/images/spacer.gif" />
    						<br /><input type="image" src="http://www.sohh.com/images/skin/default/butn_search.gif" width="58" height="18" /></td>
    If that's the case, then your problem is here:
    Code:
    style=".... background-image: url("http://www.sohh.com/images/skin/obie_trice/tile_search.gif");... "
    (emphasis added). Note your use of double quotes. You need to make one of those pairs of quotes single (conventionally the inner pair), or mark your quotes using &quote inside the style attribue, although I'm not sure how supported this is.
    Love it? Hate it? Helpful? Useless?
    Use the rate button to let me know what you think of my post!

  7. #7
    SitePoint Zealot Tygger2512's Avatar
    Join Date
    Jul 2003
    Location
    Pittsburg, KS
    Posts
    191
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ucahg
    =Note your use of double quotes. You need to make one of those pairs of quotes single (conventionally the inner pair), or mark your quotes using &quote inside the style attribue, although I'm not sure how supported this is.
    Much simpler to remove the CSS to an external stylesheet then the double quotes are no longer a problem, and the presentation is removed from the markup, in line with standards.

    Andy.
    Learn the Emotional Freedom Technique at www.as-if-by-magic.com

  8. #8
    SitePoint Addict ibeblunt's Avatar
    Join Date
    Jan 2001
    Location
    Jersey City, NJ
    Posts
    312
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I took advice from both of you and everything worked out! Thanks!
    <///////~

    www.sohh.com


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •