Quote Originally Posted by Hartmann
Don't worry, Longhorn is a lot nicer....
And it will most likely have automatic updates enabled by default. Thank god.

Oh, and new hardware will definetly be needed with Longhorn. Hardware that supports NGSCB (Palladium) will not be needed, but the new graphical interface is very advanced, and will need quite a machine to power.