SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Sep 2003
    Location
    London, UK
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    xMenu3 and IE5/Mac

    xMenu3 doesn't appear to work on IE5/Mac - I have used menu9 from the cbe library and I know this had to be adjusted slightly for IE5/Mac, mainly in the stylesheet, !DOCTYPE and the use of a table to format the downgraded menus (no changes were needed in the script). I can't be more specific about the problem at present, I'm afraid, but will post details when I have investigated further.

  2. #2
    I'll take mine raw silver trophy MikeFoster's Avatar
    Join Date
    Dec 2002
    Location
    Alabama, USA
    Posts
    2,560
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi bjorsq,

    Thanks. I don't have access to a Mac so when you get a chance to describe what's happening (or not happening) we'll try to find the problem.

  3. #3
    SitePoint Member
    Join Date
    Sep 2003
    Location
    London, UK
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Screenshots

    OK, I've done a few screengrabs to illustrate.

    First, at http://bjorsq.net/grab1.gif, the page as it loads. Horizontal menus are squashing together at the top - vertical ones look OK.

    Second, at http://bjorsq.net/grab2.gif, one of the menus on the left expanded. The problem here is that the buttons are not wide enough, and you have to move the mouse really fast to the menu so it stays visible. This is a problem in the submenus as well, although you can get them to expand after a bit of practice (http://bjorsq.net/grab3.gif).

    Not as bad as I thought at first.

  4. #4
    I'll take mine raw silver trophy MikeFoster's Avatar
    Join Date
    Dec 2002
    Location
    Alabama, USA
    Posts
    2,560
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi bjorsq,

    Thanks for the feedback!

    I made a few minor adjustments to the menu demo at the end of last week, so make sure you're testing with the latest version and make sure your browser is not getting some of the files from cache.

    In your screen-shots I notice that the font-size of the labels is different from the font-size of the items. This implies that the appropriate styles are not being applied to the label elements. Those styles are applied dynamically in xmStyleIterator() (file: xmenu3.js). Does IE5/Mac support making assignments to the className property of an element? Try some alert() statements in xmStyleIterator() to try to see what's going on - for example is box.xmLevel defined?

    Edit:

    BTW, the menu demo is now included in the Hawk download zip.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •