SitePoint Sponsor

User Tag List

Page 15 of 31 FirstFirst ... 511121314151617181925 ... LastLast
Results 351 to 375 of 767
  1. #351
    SitePoint Enthusiast
    Join Date
    Feb 2005
    Posts
    63
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    matrix and animal

    Thanks! The files are uploading and the text is being placed into their correct record cells. I haven't done it yet but I understand how to gallery into my site design. My next step is getting the photos into albums within a category.

    example - I have hundreds of lake photos. I want to further organize them by albums. ....
    Category > album > photo
    Lake > Memorial Day > photo xyz
    Lake > Memorial Day > photo 123
    Lake > forth of july > photo boat
    Lake > forth of july > photo wakeboarder

    When someone gets to the viewgallery page I'd like them to see a list of categories, then if they click on the lake category I'd like them to see a list of albums under the lake category, then they select an album to see thumbnail photos from that album.

    How should I do this?
    Thanks for all of your help!!! I'm NEW to php/mysql - 2/05

    View my progress at www.benrud.net

  2. #352
    Marc
    SitePoint Community Guest
    I'm getting the error, file 1 is not an image, for a png image... Any ideas?

  3. #353
    SitePoint Member LordChaos's Avatar
    Join Date
    Feb 2005
    Location
    Jakarta or Montreal
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Cool

    It might not be nice, hehehe, but i might want to complain a bit, i do know all of the coders are willing to help, but there is so many post with different codes it is getting hard to find out which one to use.

    Is there a way that each of you create a final version of there own script, like some did?

    I do no mean to offend anybody, it is just that i am really new in this, and to many things and screw up my learning..hehehe

    I did try some stuff tho, but i still cannot uplaod images, and even you say to put the photos files to 777, i don't even know where to do that.

    I use cpanel, and in the file manager, i went to the folder, and click the permission, there is a 3 numbers there, 7,5,5. i try to put 7,7,7, but always reset to 755. SO i guess it is not the place.

    I did like the post with the Security version, but still until now, i cannot make it work. at least until i try to upload an image, (png do not work) it tells me that "File 1 is not a photo!"

    What i am trying to do :

    For me, i want to create a main page, with some selection, drop down menu maybe. and will load a new page after your selection with ONE image, comments, and some other info about it. and thats it, i do not want to create a thumbnail.

    Image:
    Categorie:
    Info:
    Platforms:
    Productions:
    available:

    are the fields that i want to show from a DB.


    I really hope someone can help.
    Thanks alot!


    here is the error i got:

    Warning: copy(photos/0.gif): failed to open stream: Permission denied in /home/swonlimi/public_html/html/MySQL/upload.php on line 51

    Warning: getimagesize(photos/0.gif): failed to open stream: No such file or directory in /home/swonlimi/public_html/html/MySQL/upload.php on line 55

    Warning: Division by zero in /home/swonlimi/public_html/html/MySQL/upload.php on line 75

    Warning: imagecreatefromgif(photos/0.gif): failed to open stream: No such file or directory in /home/swonlimi/public_html/html/MySQL/upload.php on line 90

    Warning: imagegif(): supplied argument is not a valid Image resource in /home/swonlimi/public_html/html/MySQL/upload.php on line 101

    Warning: imagedestroy(): supplied argument is not a valid Image resource in /home/swonlimi/public_html/html/MySQL/upload.php on line 102
    HTML DESIGN-start

    File 1 Added Successfully!

    And of course the image is not there...
    Last edited by LordChaos; Feb 19, 2005 at 16:53.

  4. #354
    Anonymous
    SitePoint Community Guest
    Fatal error: Call to undefined function: imagecreatefromjpeg() in C:\Program Files\Apache Group\Apache2\htdocs\gal\upload.php on line 73

    this is the error i got, and php 4 already have gd dll and i already uncomment it in php.ini extension still same error waht will i do pls help me

    chidin

  5. #355
    Obsessive designer Infizi's Avatar
    Join Date
    May 2004
    Location
    North Pole
    Posts
    450
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by LordChaos
    It might not be nice, hehehe, but i might want to complain a bit, i do know all of the coders are willing to help, but there is so many post with different codes it is getting hard to find out which one to use.

    Is there a way that each of you create a final version of there own script, like some did?

    I do no mean to offend anybody, it is just that i am really new in this, and to many things and screw up my learning..hehehe

    I did try some stuff tho, but i still cannot uplaod images, and even you say to put the photos files to 777, i don't even know where to do that.

    I use cpanel, and in the file manager, i went to the folder, and click the permission, there is a 3 numbers there, 7,5,5. i try to put 7,7,7, but always reset to 755. SO i guess it is not the place.

    I did like the post with the Security version, but still until now, i cannot make it work. at least until i try to upload an image, (png do not work) it tells me that "File 1 is not a photo!"

    What i am trying to do :

    For me, i want to create a main page, with some selection, drop down menu maybe. and will load a new page after your selection with ONE image, comments, and some other info about it. and thats it, i do not want to create a thumbnail.

    Image:
    Categorie:
    Info:
    Platforms:
    Productions:
    available:

    are the fields that i want to show from a DB.


    I really hope someone can help.
    Thanks alot!


    here is the error i got:




    And of course the image is not there...
    Referring to your code problems ::

    I found a loop hole in the original code, that failed to recognise tha an error had occured, and then created a mass of erros. Im sure msny others did too!

    To the problem :

    My creation is well underway. Ive taken everyones comments, ideas, code snippets etc etc, and quite a few PMs about it aswell! Its developing slowly for two reasons, or maby 3?
    1 - Im in my final college year, so im working hard, on the good side my final project for Alevel computing is on PHP, the bad side is its huge, and not done.....
    2 - The code i wrote was embedded into a few files through out a site i made a while back. So i have to slowly rip it out, recode it, then make it so anyone can use it by changeing a few settigns in the config file.
    3- (there is a third!) While im developing the script, im also making a website for a client. So the script will be working when its released. But of course, this slows it down a bit, because i seem to keep adding in features etc etc.

    Otherwise mt script so far is safe, secure, and quite fast. Obviously once its released and i get feedback im sure it will speed up even more!!

    Thats all for now. As said, i will keep you posted as to when the scripts released!
    New Design - PHP Slowly flowing in!

    Infizi Studio's

  6. #356
    SitePoint Member
    Join Date
    Dec 2004
    Location
    Greensboro, NC
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Imagemagick problem

    How do I install imagmagick? I have webshell access-don't think I have shell access. (Obviously don't know what I am doing). I unpacked the imagemagick download and uploaded it into an imagemagick folder. I opened my browser and ran www.xxx.com/imagemagick/configure. It whirred for a moment then said done. I don't have any usr/local/bin folder anywhere. I had copied my downloaded gallery files into my website. When I run preupload it gives me lots of errors, but finally loads the pictures into the db. Obviously when I try to viewgallery, nothing shows up, as there are no thumbs.

    I think: 1. my imagemagick isn't installed properly and 2. the downloaded archive of the php gallery is expecting GD and not imagemagick. I wanted to use imagemagick because I thought I could upload some short .avi files with it. Can someone please help/comment on my problems? Thank you so much.

  7. #357
    SitePoint Zealot
    Join Date
    Aug 2002
    Posts
    142
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    i'm not anon. will you help me?

    I'm getting basically the same errors as this guy below, but the images aren'te even being uploaded to the /photos directory.

    I've checked the path (tried both relative and absolute) and note one thing:

    I'm on catfish, when i chmod the /photos directory to 777 as per the article, upon immediately checking it again, it's back to 755 (i've tried this about 6 times, 3 from ftp program and 3 from SSH)

    Quote Originally Posted by Anonymous
    I started coding PHP recently trying to create a photo album as explained in this usefull tutorial. But now I am stuck? I set things up as the tutorial told me, but when I try to upload some pictures I get the following error messages? Could somebody help me out with this? Thanks a lot!

    (I used the same coding as in the downloadable archive...)

    Error messages:

    Warning: copy(photos/5.jpg): failed to open stream: No such file or directory in d:webserverhtdocstestupload.php on line 51

    Warning: getimagesize(photos/5.jpg): failed to open stream: No such file or directory in d:webserverhtdocstestupload.php on line 54

    Warning: Division by zero in d:webserverhtdocstestupload.php on line 62

    Fatal error: Call to undefined function: imagecreatefromjpeg() in d:webserverhtdocstestupload.php on line 72
    here are my errors from 'upload.php'


    Warning: getimagesize(/home/<username>/public_html/photos/15.jpg): failed to open stream: No such file or directory in /home/<username>/public_html/manage/upload.php on line 113
    Warning: Division by zero in /home/<username>/public_html/manage/upload.php on line 125
    Warning: imagecreatefromjpeg(/home/<username>/public_html/photos/15.jpg): failed to open stream: No such file or directory in /home/<username>/public_html/manage/upload.php on line 135
    Warning: imagejpeg(): supplied argument is not a valid Image resource in /home/<username>/public_html/manage/upload.php on line 147
    Warning: imagedestroy(): supplied argument is not a valid Image resource in /home/<username>/public_html/manage/upload.php on line 148
    File 2 Added



    there's a red "x" (like broken image) next to the 'file 2 added' Note, the "indexing" of this upload is being added to the 'gallery_photos' table, so the form is passing data to upload.php - is it just my permissions on the photo's folder? why wont' it stay 777?

    fyi-
    line 113 is: $size = GetImageSize( $images_dir."/".$filename );
    line 125 is: $thumbnail_width = (int)(100 * $size[0] / $size[1]);
    line 135 is: $source_handle = $function_to_read ( $images_dir."/".$filename );
    line 147 is: $function_to_write( $destination_handle, $images_dir."/tb_".$filename );
    line 148 is: ImageDestroy($destination_handle );

    thanks,

    -hak

  8. #358
    SitePoint Zealot
    Join Date
    Aug 2002
    Posts
    142
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    forgot to subscribe...

  9. #359
    SitePoint Member
    Join Date
    Feb 2005
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    none of the scripts on this last section work anywhere on my site, either my call functions fail or nothing happens at all. Am I just missing a fix, or does anyone have any suggestions as to what could be wrong.
    thanks

  10. #360
    SitePoint Member
    Join Date
    Feb 2005
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Apology

    Please forget my newB post previously, I posted before investing my time to read the entire forum.

    My compliments to all the talented individuals who have contributed to this project, especially mayank and noddy, your posts have been most helpful.

    Well Done and Thanks for your time and help

    -the foo

  11. #361
    SitePoint Enthusiast
    Join Date
    Aug 2003
    Location
    Morristown, TN
    Posts
    37
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Kungfo04
    My compliments to all the talented individuals who have contributed to this project, especially mayank and noddy, your posts have been most helpful.
    Don't forget drewf. He probably posted the first downloadable code that completely worked. I think he did the login system and got all the admin functions to work. We all have made contributions to this project, but if you are going to list major contributers, don't forget him. I am indebted to him for the image resize on upload. He solved that when no-one else wanted to and I couldn't. I gave us the thumbnail pagination and javscript confirm on delete. Minor additions, but I am proud to have helped.

  12. #362
    SitePoint Zealot
    Join Date
    Aug 2002
    Posts
    142
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    and my issue was a (relative) path issue. thanks to all.

  13. #363
    SitePoint Member
    Join Date
    Feb 2005
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    My Bad...Again

    DrewF most certainly must not be forgotten, as his code was impeccable and wholly deserving of recognition and appreciation. Once again to all those who contributed, well done and thanks for the countless hours spent bringing this project from its infancy.
    Many Thanks

    -the foo

  14. #364
    Obsessive designer Infizi's Avatar
    Join Date
    May 2004
    Location
    North Pole
    Posts
    450
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hehe, talking of major coding steps....

    My Gallery code if basically done now, so i am need of a few testers, just to run it on their server, report any errors, and code improvements,,,,

    Please PM me if you would like to help
    New Design - PHP Slowly flowing in!

    Infizi Studio's

  15. #365
    SitePoint Guru
    Join Date
    Aug 2004
    Location
    Earth
    Posts
    724
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hey,

    Where is the filesize limit in this script .. I cant find it ..

    If I upload files of a certain size .. it goes thru the process .. but nothing is uploaded at all .. when the process is finished it just echos the link back to the admin page .. there is no error message saying image is to large in file size?

    Tnx
    Last edited by _matrix_; Mar 13, 2005 at 21:26.

  16. #366
    arq. Milos Korac
    SitePoint Community Guest
    This is a code that i was looking. I have a database for real estate agency, and most dificult for me (fresh new in php) was to have a fotos in a column. I was always working with html, so it is visual problem.
    And the thing about php is that there is a tons of scripts and codes on the net, free and commercial, and very few, like this one, explain it all. For me php and mysql is something completely new, and at first i was against it (writing codes and stuff) but how the time is passing, probably i will start making tons + one script for php and mysql. There should be one GOOD script with a multi template task, so in it, you can choose the field of your work.

  17. #367
    SitePoint Member
    Join Date
    Aug 2004
    Location
    sc
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hi all.
    im having a bit of a problem.
    i keep getting an ofset error like :

    Notice: Undefined offset: 1 in \htdocs\gallery\upload.php on line 27

    the wierd part is it gives me this eror 5 times even if i set the loop to only 2.
    im not a professional but i rechecked the code and cant figuer whats wrong.
    i even got the original code of this tutorial and i'm still having the same problem.
    the only modefication i did was that i removed the thumbs parts because i dont have GD.

    anyone can explain this to me please?

    thanks
    Nusa

  18. #368
    SitePoint Enthusiast St. Anger's Avatar
    Join Date
    Nov 2003
    Location
    R'lyeh
    Posts
    76
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Is there any way to add support for .psd Adobe Photoshop images?

  19. #369
    SitePoint Member
    Join Date
    Apr 2005
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question this error just popped out of the blue!

    First of all, Hi everyone... I've been browsing this site for a long time but just made an account tonight.

    Second of all, thanks to everyone that worked on this script, I have often thought about trying to make something like this, but now looking at the finished code and knowing my current php skill level, i can see it would have taken me a long, long, frustrating time to make somethingthat would work half as well.

    I have read the entire post, and ran some searches for the errors im getting (in case i missed something while reading) but didnt find anything.

    I am getting the following error at the upload confirmation stage (upload.php)

    Warning: Cannot send session cache limiter - headers already sent (output started at /*/*/*/*/*/photo_gallery/design.inc.php:3) in /*/*/*/*/*/photo_gallery/security.inc.php on line 3

    I have been making slight changes to the code (formatting, only showing certain navigation options, opening pics in a blank window) and so i expected to encounter errors, which i have fixed for the most part.

    the confusing part of this is that I haven't modified either upload.php or preupload.php

    the only thing i can think that might be connected is that i removed the login boxes from the gallery page and placed them on a seperate page, but the headers are sent on every page request right? so that wouldn't fudge things up i dont think...


    anyways, maybe someone knows the answer to this or can help me.


    oh, one more thing, so far i havent noticed that this is impacting the functionality yet, the images still upload and display ok, it just spews out some error messages after each upload.


    and thanks again for the awesome gallery, i think the best thing about it compared to others out there is that it is easily skinnable and the code isnt too convoluted to prevent a php newb from jumping in and modding it.

    // quick edit - exactly why would you want to display .psd files? browsers cant render them yet i dont think, nor could php resize them... plus your server operator would get pretty irked at the size a gallery full of psd's would take up.

  20. #370
    Fully Sweet Car noddy's Avatar
    Join Date
    Aug 2002
    Location
    Perth, Western Australia
    Posts
    759
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You will need to post up the page thats causing the error so we can read through your code and point out what may be causeing your errors.

  21. #371
    SitePoint Enthusiast
    Join Date
    Mar 2005
    Posts
    38
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by VeXeL
    Warning: Cannot send session cache limiter - headers already sent (output started at /*/*/*/*/*/photo_gallery/design.inc.php:3) in /*/*/*/*/*/photo_gallery/security.inc.php on line 3
    headers are a tricky animal. shiflett has a guru speak article that mentions the topic, but after reading it several times i still don't get it. do a search and you'll find a link to the article in this forum (if not this very thread).

    to address the header issue you mention above, comment out the header lines and i bet your errors go away. headers boil down to this: you CANNOT have a header line after ANYTHING is displayed to the browser. make sure you have no echo's or html markup before using any php header commands.

    hope that helps...

  22. #372
    SitePoint Member
    Join Date
    Apr 2005
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i'll post my code in a bit, im busy atm, and its kinda in between stages, but i think it may be that i moved the doctype tag to the top of the page>edit : (because it was going into quirks mode in ie otherwise), i'll experiment and edit this post later, either with my code or the solution to my problem

  23. #373
    SitePoint Member
    Join Date
    Apr 2005
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Wow! I just read all 15 pages of the forum and unexpectedly did not find someone who had the save problem as me.

    preupload.php works fine, the pics upload just fine (I saw them in my online directory), but I get a blank page when I tried to use viewgallery.php

    In my search I found out about admin.php and tried it both in the photos gallery folder and along with the other php files, but get the same error:

    Parse error: parse error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in /hsphere/local/home/internet/testing001.com/test-folder/phpandmysql/photo-upload/admin.php on line 59

    Here is the code around line 59:
    <form name="photo_move" action="admin2.php" method="post">

    <b>Move Photo/b><br />
    Select New Category: <?php echo($category_list); ?><br />
    Caption: <input type="text" name="caption" value="<?php //line59 echo($row["photo_caption"]); ?>" /><br />
    <input type="hidden" value="<?php echo($_POST['photoid']); ?>" name="photoid" />
    <input type="submit" value="save" name="action" />

    I saw an error like this in a previous post, but on a differant page. That didn't help me much.

    Any suggestions?
    Michael

  24. #374
    leavethisplace
    SitePoint Community Guest
    None of this tutorial worked for me, it seemed to be riddled with errors.

    For a start, it had problems with $photo_upload_fields, so i had to change the way they were set, and called - fair enough, some servers are funny about how variables are set.

    But then i just got a bunch of errors when trying the upload.php:

    Warning: move_uploaded_file(/photos/6.jpg) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/thegourm/public_html/poeticinjustice/upload.php on line 52

    Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpFJzrpo' to '/photos/6.jpg' in /home/thegourm/public_html/poeticinjustice/upload.php on line 52

    Warning: getimagesize(/photos/6.jpg) [function.getimagesize]: failed to open stream: No such file or directory in /home/thegourm/public_html/poeticinjustice/upload.php on line 55

    Warning: Division by zero in /home/thegourm/public_html/poeticinjustice/upload.php on line 63

    Warning: imagecreatefromjpeg(/photos/6.jpg) [function.imagecreatefromjpeg]: failed to open stream: No such file or directory in /home/thegourm/public_html/poeticinjustice/upload.php on line 73

    Warning: imagejpeg(): supplied argument is not a valid Image resource in /home/thegourm/public_html/poeticinjustice/upload.php on line 85

    Warning: imagedestroy(): supplied argument is not a valid Image resource in /home/thegourm/public_html/poeticinjustice/upload.php on line 86


    So, so far I'm happy to rate this tutorial at 0, and after I rated this previous articles so highly.

  25. #375
    SitePoint Member
    Join Date
    Apr 2005
    Posts
    16
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi.
    I've gotten the gallery working as the tutorial adviced, but now I'd like
    to add more than just the caption under the image. I'd like to add the possibility to add the date the image was made, with what program it was made etc. as different input fields in the upload page.

    I thought it would work, if I just copy the way the caption was made, but it didn't work, I tried to add another input like that, but then the image was always saved as 0.jpg, and nothing was inserted into the database. There were no errors when uploading the image though.

    So I would appreciate if someone could tell me what should be done differently to add more than the caption?

    Thank you.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •