SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    Life is not a malfunction gold trophysilver trophybronze trophy
    TechnoBear's Avatar
    Join Date
    Jun 2011
    Location
    Argyll, Scotland
    Posts
    6,374
    Mentioned
    268 Post(s)
    Tagged
    5 Thread(s)

    Google Maps Pro still shows "for non-commercial use"

    (I have no idea which forum this best belongs in, so if anybody has a better idea, please feel free to move it. )

    Google maps basic (free) version states it's not for commercial use, so I upgraded to Google Maps Pro. When I create and edit a map, it shows "Google Map Engine Pro" in the lower left corner. When I embed the map in my site, it shows simply "Google Map Engine" and the message about it being for non-commercial use.

    Ok, so I know I've paid, I have the receipt and Google aren't going to be suing me, but it doesn't look very professional to have "for non-commercial use" displayed on commercial sites.

    Does anybody know what's going on here? (And better still, if there's any way to fix it. )

  2. #2
    SitePoint Mentor silver trophy
    Rubble's Avatar
    Join Date
    Dec 2005
    Location
    Cambridge, England
    Posts
    2,435
    Mentioned
    82 Post(s)
    Tagged
    3 Thread(s)
    Google is you friend:
    Yes, it is, the users do not have the Pro version and get that watermark.
    It is not ideal, the issue was brought to the attention of Google employees but I have no idea if they are going to do anything about it.
    Looks like both parties need the Pro version to remove the watermark.

  3. #3
    Life is not a malfunction gold trophysilver trophybronze trophy
    TechnoBear's Avatar
    Join Date
    Jun 2011
    Location
    Argyll, Scotland
    Posts
    6,374
    Mentioned
    268 Post(s)
    Tagged
    5 Thread(s)
    Quote Originally Posted by Rubble View Post
    Google is you friend:
    I beg to differ there , but thanks for the quote. I couldn't find anything.

    Quote Originally Posted by Rubble View Post
    Looks like both parties need the Pro version to remove the watermark.
    Not sure what you mean by that. If I visit my page, with my map, while logged into Google, it still shows the "non-commercial message" - even though I can see the "pro" version in another tab.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •