SitePoint Sponsor

User Tag List

Results 1 to 18 of 18
  1. #1
    SitePoint Member
    Join Date
    Mar 2014
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Lightbulb I cant install xampp software in my laptop win7 32bit

    so i will share my screenshot where problem occurred and how ? How and why ans expecting from you!!!
    first i cant start apache option in xampp software. but mySQL is on when i click but not Apache.. please look those screenshot and pleas help me to solved this case.
    Attached Images Attached Images

  2. #2
    SitePoint Wizard
    Join Date
    Oct 2005
    Posts
    1,832
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    First thing first: temporarily disable your firewall. You can re-enable it later, ensuring you are not blocking ports 80, 443, (Apache web server) or 3306 (MySQL).

    You installed XAMPP outside of your Program Files folder, which is good.

    Did you run XAMPP as administrator? In the Start Menu or on your desktop icon, right click on Xampp Control Panel and select "Run as administrator". XAMPP prefers to run with administrator privileges.

    I am running XAMPP on Windows 7 64-bit. It looks like XAMPP should run fine on 32 bit.

    Post your Apache error log. Hit the "logs" button and look at the error log to see if you can find out why Apache will not start. It may be something simple.

    I will check back in 8 - 10 hours after I wake up and read the news.

  3. #3
    SitePoint Member
    Join Date
    Mar 2014
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    i have tried again but same results

    i stopped my firewall but no result . also run as administrator.... please see my attachment and give me instruction ....
    Attached Images Attached Images

  4. #4
    From space with love silver trophy
    SpacePhoenix's Avatar
    Join Date
    May 2007
    Location
    Poole, UK
    Posts
    5,016
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    Try disabling User Account Control (part of Windows) as it may be interfering with how XAMP loads up
    Community Team Advisor
    Forum Guidelines: Posting FAQ Signatures FAQ Self Promotion FAQ
    Help the Mods: What's Fluff? Report Fluff/Spam to a Moderator

  5. #5
    SitePoint Member
    Join Date
    Mar 2014
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by SpacePhoenix View Post
    Try disabling User Account Control (part of Windows) as it may be interfering with how XAMP loads up
    How can i disabling user account control ? How ?

  6. #6
    SitePoint Wizard
    Join Date
    Oct 2005
    Posts
    1,832
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    I am not familiar with your drive setup. Do you have a C: drive? If so, is there a reason you installed it on D:? A quick search shows a few complaints of XAMPP not working when installed on a D: partition (and some say it does work). D: partitions are often reserved for backup files. Did you examine the Apache error log as I mentioned last night? Why don't you post the error log here so we can see it. Obscure any sensitive info if you need to.

    Take a look at this for disabling User Account Control

    http://www.mydigitallife.info/how-to...-in-windows-7/

    Not running as administrator (which you say you are doing now) and having another program listening on port 80 are common causes for XAMPP not loading properly. In your XAMPP control panel on the Apache line, click the "Logs" button and select the error log and post it here. Also, you could try not only disabling your firewall, but your anti-virus software temporarily as well.

    We can find out more if you post your error log.

  7. #7
    SitePoint Member
    Join Date
    Mar 2014
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yeah i am trying to folllow your instruction wait, i will known u tomorrow , but it seems too complicated..

  8. #8
    SitePoint Member
    Join Date
    Mar 2014
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    suppose i am trying to follow your links its too complicated
    Last edited by remonx6; Mar 26, 2014 at 12:52. Reason: fixxing

  9. #9
    SitePoint Member
    Join Date
    Mar 2014
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    and I am using broadband internet , i am not sure about port 80? How can i get it
    .

  10. #10
    SitePoint Wizard
    Join Date
    Oct 2005
    Posts
    1,832
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    In your picture:

    http://www.sitepoint.com/forums/atta...0&d=1395726075

    See the "Logs" button on the right of the Apache row? Click that button, select Apache (error.log), and we can see what kind of errors Apache is throwing. Did you move the htdocs folder or many any other change to the configuration files?

  11. #11
    SitePoint Wizard bronze trophy
    Join Date
    Jul 2006
    Location
    Augusta, Georgia, United States
    Posts
    4,147
    Mentioned
    16 Post(s)
    Tagged
    3 Thread(s)
    Quote Originally Posted by remonx6
    yeah i am trying to folllow your instruction wait, i will known u tomorrow , but it seems too complicated..
    If you think this is complicated try compiling a lamp stack from source on a windows machine then you will know the true struggle :/

    You could try reinstalling xampp and see if the problem fixes itself. I ran into issues the last time I installed xampp but a reinstall did the trick.
    The only code I hate more than my own is everyone else's.

  12. #12
    SitePoint Member
    Join Date
    Mar 2014
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i have idea ... we can use team viewer then u can solved my problem

  13. #13
    SitePoint Member
    Join Date
    Mar 2014
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    its last message after reinstall..Xampp
    Attached Images Attached Images

  14. #14
    SitePoint Member
    Join Date
    Mar 2014
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by cheesedude View Post
    In your picture:

    http://www.sitepoint.com/forums/atta...0&d=1395726075

    See the "Logs" button on the right of the Apache row? Click that button, select Apache (error.log), and we can see what kind of errors Apache is throwing. Did you move the htdocs folder or many any other change to the configuration files?
    ITs blank notepad.

  15. #15
    SitePoint Member
    Join Date
    Mar 2014
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello
    I am waiting for your reply ...still its not working ..

  16. #16
    SitePoint Wizard
    Join Date
    Oct 2005
    Posts
    1,832
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by remonx6 View Post
    Hello
    I am waiting for your reply ...still its not working ..
    I have been busy.

    If you type 127.0.0.1 into your browser's address bar, do you get anything or just an error message?

    If you installed XAMPP on your main hard drive, disabled your firewall software from interfering with communications (including the built-in Windows Firewall), and allowed XAMPP to run as administrator, it should work unless you made changes to the configuration files. The only other possibility I can think of is that there is another programming listening on port 80 and that is preventing Apache from binding on that port and causing it to shutdown immediately.

    Let's look at what programs are listening on your ports and see if anything is listening on port 80. Go to your command line program. In Windows, you can go to Start Menu and in the search box type "cmd". Or you can go to Start Menu -> All Programs -> Accessories -> Command Prompt. When you get your Command Prompt opened, type this command in it:

    Code:
    netstat -aon
    That will list all active programs listening for connections and the ports they are listening on. Near the top of the output, look for something like this in the Local Address column:

    Code:
    0.0.0.0:80
    If you see that line with the State column showing LISTENING, you already have a program listening on that port. If you do not see it, that is good because that cannot be the cause of your problem.

    Other than a program already listening on port 80, I am out of ideas. I think that when XAMPP is setup you can choose to install Apache as a service. If you did that (and I do not know if you did), it would mean that Apache is already running as a service. If Apache is already installed as a service, it would show in the Services section of the Administrative Tools area of the Control Panel.

    I am out of ideas. If that doesn't help, then try downloading XAMPP again and reinstalling to another folder on your main hard drive.

  17. #17
    From space with love silver trophy
    SpacePhoenix's Avatar
    Join Date
    May 2007
    Location
    Poole, UK
    Posts
    5,016
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    Try re-installing it at C:\
    Community Team Advisor
    Forum Guidelines: Posting FAQ Signatures FAQ Self Promotion FAQ
    Help the Mods: What's Fluff? Report Fluff/Spam to a Moderator

  18. #18
    SitePoint Member
    Join Date
    Jun 2014
    Location
    chicago
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    why struggling with the XAMP with windiws os. just try WAMP server and get everything fixed. though WAMP server has many relevant features of the XAMP server.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •