SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Evangelist tangledman's Avatar
    Join Date
    Sep 2005
    Location
    Puerto de Mazarron, Murcia, Spain
    Posts
    425
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Debugging - I have the script working in one location but not another.

    Hi Everyone,

    i'm stuck on trying to do an ajax autocomplete.

    The autocomplete script works here:

    http://www.spanishproperty.es/ajax/autosuggest/

    but not here:

    http://spanishproperty.es/index.php?...on=search_town

    I can't see why. Please help

  2. #2
    Programming Team silver trophybronze trophy
    Mittineague's Avatar
    Join Date
    Jul 2005
    Location
    West Springfield, Massachusetts
    Posts
    17,183
    Mentioned
    191 Post(s)
    Tagged
    2 Thread(s)
    They are not the same

    The working page has
    HTML Code:
    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.js"></script>
    and is using the non-min version
    jQuery JavaScript Library v1.3.2

    The non-working page has
    HTML Code:
    <script  type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js"></script>
    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.js"></script>
    and near the bottom
    HTML Code:
    <script src="http://www.spanishproperty.es/js/jquery.min.js"></script>
    and has loaded these three (one non-min and two min)
    jQuery JavaScript Library v1.3.2
    jQuery v1.9.1
    jQuery v2.0.3

    So who knows which is being used?
    Can you make the non-working page more like the working page? i.e.
    comment out the 2 non-min script tags


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •