SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Evangelist
    Join Date
    Feb 2005
    Location
    London, UK
    Posts
    422
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Tipue Search - Search Engine For Your Site

    Hello all. Having some trouble getting a search engine plugin to work.

    I've followed the step by step guide for 'Live Mode' http://www.tipue.com/search/docs/#live

    I currently have three pages on my site:

    index.html
    Code:
    <!doctype html>
    <html lang="en">
    
    	<head>
    		<meta charset="UTF-8">
    
    		<title>Document</title>
    
    		<link href="http://fonts.googleapis.com/css?family=Open+Sans:300,400" rel="stylesheet">
    		<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.0.3/jquery.min.js"></script>
    		<link href="tipuesearch/tipuesearch.css" rel="stylesheet">
    		<script src="tipuesearch/tipuesearch_set.js"></script>
    		<script src="tipuesearch/tipuesearch.js"></script>
    	
    	</head>
    
     <body>
      
    	<h1>SEARCH PAGE</h1>
    
    	<form action="search.html">
    	<div style="float: left;"><input type="text" name="q" id="tipue_search_input"></div>
    	<div style="float: left; margin-left: 13px;"><input type="button" id="tipue_search_button" onclick="this.form.submit();"></div>
    	<div style="clear: left;"></div>
    	</form>
    
     </body>
    
    </html>
    search.html
    Code:
    <!doctype html>
    <html lang="en">
    
    	<head>
    		<meta charset="UTF-8">
    
    		<title>Document</title>
    
    		<link href="http://fonts.googleapis.com/css?family=Open+Sans:300,400" rel="stylesheet">
    		<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.0.3/jquery.min.js"></script>
    		<link href="tipuesearch/tipuesearch.css" rel="stylesheet">
    		<script src="tipuesearch/tipuesearch_set.js"></script>
    		<script src="tipuesearch/tipuesearch.js"></script>
    	
    	</head>
    
     <body>
      
    	<h1>RESULTS PAGE</h1>
    
    	<div style="float: left;"><input type="text" id="tipue_search_input"></div>
    	<div style="float: left; margin-left: 13px;"><input type="button" id="tipue_search_button"></div>
    	<div id="tipue_search_content"><div id="tipue_search_loading"></div></div>
    
    
    <script>
    $(document).ready(function() {
         $('#tipue_search_input').tipuesearch({
              'mode': 'live',
              'liveDescription': '.header',
              'liveContent': '.container'
         });
    });
    </script>
    
     </body>
    
    </html>
    content.html
    Code:
    <!doctype html>
    <html lang="en">
     <head>
      <meta charset="UTF-8">
      <meta name="Generator" content="EditPlusŪ">
      <meta name="Author" content="">
      <meta name="Keywords" content="">
      <meta name="Description" content="">
      <title>King Search Test</title>
     </head>
     <body>
      <p>
    	The King and I is a musical by the team of composer Richard Rodgers and dramatist Oscar Hammerstein II. It is based on the 1944 novel Anna and the King of Siam by Margaret Landon, which derives from the memoirs of Anna Leonowens, governess to the children of King Mongkut of Siam in the early 1860s. The musical relates the experiences of Anna, a British schoolteacher hired as part of the King's drive to modernize his country. Their relationship is marked by conflict through much of the piece, and a love that neither can admit. Rodgers and Hammerstein wrote the musical for veteran star Gertrude Lawrence. Rex Harrison, who played the King in the 1946 movie of Landon's book, was unavailable, so Yul Brynner was chosen. The musical premiered in March 1951 at Broadway's St. James Theatre and ran nearly three years. It was an immediate hit, winning Tony Awards for Best Musical and for Best Actress and Best Featured Actor for Lawrence and Brynner (pictured). A hit London run and U.S. national tour followed, together with a 1956 film for which Brynner won an Academy Award. Professional and amateur revivals of The King and I are staged regularly throughout the English-speaking world.
      </p>
     </body>
    </html>
    It's very straightforward. The last bit of the tutorial says to upload the Tipue folder (which I've done) and lastly populate the tipuesearch_set.js file.. which I have

    tipuesearch_set.js
    Code:
    /*
    Tipue Search 3.1
    Copyright (c) 2013 Tipue
    Tipue Search is released under the MIT License
    http://www.tipue.com/search
    */
    
    
    var tipuesearch_stop_words = ["and", "be", "by", "do", "for", "he", "how", "if", "is", "it", "my", "not", "of", "or", "the", "to", "up", "what", "when"];
    
    var tipuesearch_replace = {"words": [
         {"word": "tipua", replace_with: "tipue"},
         {"word": "javscript", replace_with: "javascript"}
    ]};
    
    var tipuesearch_stem = {"words": [
         {"word": "e-mail", stem: "email"},
         {"word": "javascript", stem: "script"},
         {"word": "javascript", stem: "js"}
    ]};
    
    var tipuesearch_pages = ["http://s148733952.websitehome.co.uk/content.html"];
    This is the website: http://s148733952.websitehome.co.uk/

    When i search it always returns 'nothing found' which tells me the content.html file isn't being indexed or I've missed something.

    HELP!

  2. #2
    SitePoint Evangelist
    Join Date
    Feb 2005
    Location
    London, UK
    Posts
    422
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok basically I emailed the developers and they got back to me.

    As I have not defined a .header or .container in my content.html page I should remove them from the script at the end of my search results page:

    Code:
    <script>
    $(document).ready(function() {
         $('#tipue_search_input').tipuesearch({
              'mode': 'live',
              'liveDescription': '.header',
              'liveContent': '.container'
         });
    });
    </script>
    becomes

    Code:
    <script>
    $(document).ready(function() {
         $('#tipue_search_input').tipuesearch({
              'mode': 'live'
         });
    });
    </script>
    I've made that adjustment and am still getting Nothing found. Hoping I get a solution shortly.

    Thanks

  3. #3
    SitePoint Evangelist
    Join Date
    Feb 2005
    Location
    London, UK
    Posts
    422
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I managed to get it working. It didn't find any results because I was testing the plugin on a sub-domain and wasn't declaring the search set properly.

    All good. Thanks


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •