SitePoint Sponsor

User Tag List

Results 1 to 17 of 17
  1. #1
    SitePoint Enthusiast
    Join Date
    Jul 2011
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Upgraded MySQL - How to Associate New MySQL Server in PHPMyAdmin?

    I just upgraded MySQL but when I log into phpMyAdmin, it still shows the old MySQL server. How can I associate phpMyAdmin with the latest version of MySQL just installed? Any recommendations will be greatly appreciated.

  2. #2
    SitePoint Enthusiast
    Join Date
    Jul 2011
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    No one else has run into this issue? I am using phpMyAdmin 4.0.10 and I just installed MySQL 5.6. PHPMyAdmin is showing Server version: 5.5.23 when I log in, which is the previous MySQL version.

    Any help is appreciated.

  3. #3
    From space with love silver trophy
    SpacePhoenix's Avatar
    Join Date
    May 2007
    Location
    Poole, UK
    Posts
    5,014
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    Have you rebooted the server?
    Community Team Advisor
    Forum Guidelines: Posting FAQ Signatures FAQ Self Promotion FAQ
    Help the Mods: What's Fluff? Report Fluff/Spam to a Moderator

  4. #4
    SitePoint Enthusiast
    Join Date
    Jul 2011
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by SpacePhoenix View Post
    Have you rebooted the server?
    Thanks for your response. It is much appreciated. Unfortunately I have tried rebooting the server to no avail. Any other recommendations are appreciated.

  5. #5
    SitePoint Addict
    Join Date
    Aug 2013
    Location
    New Zealand
    Posts
    277
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    How do you know the new version installed correctly? If it didn't and it was installed through a package manager then it may have even been rollws back automatically

  6. #6
    SitePoint Wizard
    Join Date
    Oct 2005
    Posts
    1,832
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    Did you try updating phpMyAdmin? You can check your MySQL server version through the command line. Is it your phpMyAdmin client library that is showing a previous version? I am just learning Linux myself. From what I have read, sometimes you have update, reinstall, or recompile something against a newer version of something else. For example, if you install a new version of MySQL, you may need to update your PHP as well.

  7. #7
    SitePoint Addict
    Join Date
    Aug 2013
    Location
    New Zealand
    Posts
    277
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by cheesedude View Post
    From what I have read, sometimes you have update, reinstall, or recompile something against a newer version of something else.
    I wouldn't have thought you would need to do that if you're using a package manager like yum or apt-get. I recently upgraded mysql on centos using yum and it went and found and upgraded all dependencies for me. I should think it would be not much different for Ubuntu. For the far majority of cases you shouldn't need to compile from source these days and it should be avoided if at all possible.

  8. #8
    SitePoint Addict
    Join Date
    Aug 2013
    Location
    New Zealand
    Posts
    277
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    If you type the following into the shell you should see what version you have installed.

    $ mysql --version

    See the dot seperated numbers after the "Distrib" string. This is your mysql version number.

  9. #9
    SitePoint Enthusiast
    Join Date
    Jul 2011
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I installed using the Windows installer (ref: http://dev.mysql.com/downloads/installer/) and I have since discovered that even after a successful install, the only Windows service was the old one 5.5. As a result, i stopped that service and re-installed and it created a new Windows service for the new version. I made sure the service for the old version was stopped and the new service started but now I can't login to phpMyAdmin even with the root user. I am getting the "#2002 Cannot log in to the MySQL server" error. At least now I know the new version is running and I can log into the MySQL 5.6 Command Line Client using the root user password that won't work in phpMyAdmin. I have added the following code to the config.inc.php file but it still won't let me login to phpMyAdmin.

    Code:
    $cfg['Servers'][$i]['user'] = 'root'; //mysql username here
    $cfg['Servers'][$i]['password'] = 'password'; //mysql password here
    Also once I solve the login issue, how do I get rid of the old MySQL windows service?

  10. #10
    SitePoint Wizard
    Join Date
    Oct 2005
    Posts
    1,832
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by ZosoKat View Post
    I installed using the Windows installer
    I assumed you were using Linux. When I was installing a development server on a new computer last year I went with XAMPP because it was impossible to find recent versions of Windows binaries for Apache, PHP, and MySQL that would work together. XAMPP is so much easier and everything is relatively current.

    http://www.apachefriends.org/index.html

    Quote Originally Posted by ZosoKat View Post
    Also once I solve the login issue, how do I get rid of the old MySQL windows service?
    Did you try uninstalling it in the Windows uninstall feature in Control Panel?

    http://dev.mysql.com/doc/refman/5.1/...nstalling.html

    To uninstall a MySQL where you have used the MSI packages, you must use the Add/Remove Programs tool within Control Panel.

  11. #11
    SitePoint Enthusiast
    Join Date
    Jul 2011
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I had to uninstall both versions of MySQL (5.1 and 5.6) and then re-install 5.6 using the Windows installer.

    Windows 7
    IIS 7.5
    PHP 5.4
    phpMyAdmin 4.1.7

    After uninstalling both versions of MySQL, then successfully re-installing 5.6, I was able to login to PHPMyAdmin. Next I created the phpmyadmin db and ran the script that came with phpmyadmin code to create the tables for phpmyadmin and I created a pma user. After doing all that, now I can't login to phpMyAdmin! I get two errors:

    " #2002 Cannot log in to the MySQL server" AND "Connection for controluser as defined in your configuration failed."

    If I comment out this code, the "Connection for controluser as defined in your configuration failed." error message goes away.

    $cfg['Servers'][$i]['controlhost'] = '';
    $cfg['Servers'][$i]['controlport'] = '';
    $cfg['Servers'][$i]['controluser'] = 'pma';
    $cfg['Servers'][$i]['controlpass'] = 'insert_password_here';

    Should I uninstall phpMyAdmin and re-install? Really getting frustrated at this point. Thanks for all the replies - it has helped me get this far.

  12. #12
    SitePoint Enthusiast
    Join Date
    Jul 2011
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Something keeps causing the MySQL Windows service to stop so I have to restart it manually.

  13. #13
    From space with love silver trophy
    SpacePhoenix's Avatar
    Join Date
    May 2007
    Location
    Poole, UK
    Posts
    5,014
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ZosoKat View Post
    Something keeps causing the MySQL Windows service to stop so I have to restart it manually.
    Is there any recurring entries in any error logs?
    Community Team Advisor
    Forum Guidelines: Posting FAQ Signatures FAQ Self Promotion FAQ
    Help the Mods: What's Fluff? Report Fluff/Spam to a Moderator

  14. #14
    SitePoint Wizard
    Join Date
    Oct 2005
    Posts
    1,832
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    A quick Yahoo search shows a few complaints for MySQL 5.6 stopping on Windows 8. Original poster did not provide OS version.

  15. #15
    SitePoint Enthusiast
    Join Date
    Jul 2011
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by cheesedude View Post
    A quick Yahoo search shows a few complaints for MySQL 5.6 stopping on Windows 8. Original poster did not provide OS version.
    I guess I didn't post the OS because I am working with multiple environments, but they are Win 7 and Win Server 2008 R2. Interesting note about MySQL 5.6 and Win 8 issues.

  16. #16
    SitePoint Addict
    Join Date
    Jun 2005
    Posts
    262
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ZosoKat View Post
    No one else has run into this issue? I am using phpMyAdmin 4.0.10 and I just installed MySQL 5.6. PHPMyAdmin is showing Server version: 5.5.23 when I log in, which is the previous MySQL version.

    Any help is appreciated.
    It happened to me recently. I believe phpMyAdmin caches some general settings/attributes within a cookie (or localStorage) which includes the MySQL version number. I resolved it by clearing my browser's cookies. If that doesn't work, clear your local storage.

  17. #17
    SitePoint Enthusiast
    Join Date
    Jul 2011
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by champ View Post
    It happened to me recently. I believe phpMyAdmin caches some general settings/attributes within a cookie (or localStorage) which includes the MySQL version number. I resolved it by clearing my browser's cookies. If that doesn't work, clear your local storage.
    Thx for that information. It is much appreciated.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •