Not sure if this is the right place to put this...

I posted in the .org support forums, but posts get lost pretty quickly there!

I moved my site from http://peterchamberlaincann.wordpress.com to http://www.peterchamberlaincann.co.uk a few weeks ago. I've made a lot of changes to the theme using a child, but there's some I can't figure out how to do:

-The text and images are stuck to the old 520px "margins" on the Portfolio page, and in WP dashboard when I'm editing a post. It displays Portfolio correctly in Safari (http://s3.postimg.org/y9z3bcxqr/wp1.png) but not in Firefox (http://s3.postimg.org/mjl5tz4yb/wp2.png) or Internet Explorer. This is how it looks in the dashboard (http://s3.postimg.org/bmju57i6r/wp3.png).

-I want to put the sidebar back in, but only on the Blog and all the pages related to that. This is the code that will bring the sidebar back I think:
Code:
.entry-meta {
    display: inline;
}

.wide {
    float: right;
    width: 520px;
}

.hentry {
    margin: 0 0 40px;
}
-In the Leave a Reply box, the two "Notify me" sentences are positioned in the wrong place, separate from the checkboxes, but I'm not sure where they're meant to go. http://www.peterchamberlaincann.co.u.../pendulum-rig/

-I think because I extended the main column from 520px to 720px, it doesn't display correctly on my phone or tablets.

-Remove the underline that appears on the footer buttons when hovered over.

-Footer buttons appear light blue (hover colour) in Firefox on Windows ?!? http://s3.postimg.org/lzgltt8lf/wp4.png

-I added this code to change the line spacing between images for the Portfolio page, but it has resulted in all gaps between headers and images (as seen here http://www.peterchamberlaincann.co.uk/blog/berlin/) being too small.
Code:
.entry-content.wide img { margin-bottom: 6px; }