SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Jul 2003
    Location
    Chesterfield
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Smile MySQL Service Won't Run

    I've been following Kevin Yank's book on PHP & My SQL. I've installed on Windows XP Pro:

    MySQL 4.0.13
    PHP 4.3.2
    IIS

    I ran "mysqld-nt --install", which returned "Service successfully installed." However, it does not show up in Windows Task Manager. I rebooted the computer and ran it again, and I got the message:

    The service already exists.
    The current server installed: D:\Programs\mysql\bin\mysqld-nt

    When I try to change the password I get:

    ERROR 2003: Can't connect to MySQL server on 'localhost' (10061)

    Any suggestions?

    j.
    Last edited by jalandoak; Jul 22, 2003 at 16:44.

  2. #2
    SitePoint Evangelist
    Join Date
    Mar 2003
    Location
    Melbourne, Australia
    Posts
    463
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    did you run that line that says
    net start mysql

  3. #3
    SitePoint Member
    Join Date
    Jul 2003
    Location
    Chesterfield
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I hadn't originally--I thought I didn't need to with a reboot--but I ran it now. The system returned:

    The MySQL service was started successfully.

    However, it still doesn't show up under processes, and I get the same error when I try to change the root password.

    j.

  4. #4
    SitePoint Member
    Join Date
    Jul 2003
    Location
    Chesterfield
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It works. I moved my.cnf to my.ini and everything started working as advertised.

  5. #5
    SitePoint Zealot
    Join Date
    Mar 2002
    Posts
    169
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i also have this problem, but what i type "net start mysql" it says:


    system error 3 has occured

    the system cannot find the path specified


    what path? specified where?

  6. #6
    SitePoint Member a0395335's Avatar
    Join Date
    Sep 2003
    Location
    Plano Texas
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Same problem ... help!

    I am getting this same problem. Windows 2000, current version of MySql, IIS. I have been following Kevin's book as well, but I am sure that I have missed something ...
    Any suggestions would be welcome.

    Quote Originally Posted by spollin
    i also have this problem, but what i type "net start mysql" it says:


    system error 3 has occured

    the system cannot find the path specified


    what path? specified where?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •