SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Enthusiast
    Join Date
    Aug 2008
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Main Nav in mobile view not working

    I've got few items on a single website that I need help with.

    1. Mobile Nav Not Working

    I'm working on a website based on a Concrete5 theme that was modified. Here is the original theme that works as expected:

    http://structura.c5mix.com/

    When you go down to the mobile view, the main menu collapse and all you see is "Menu"

    Click/Tap "Menu", then "About" and everything works fine.

    On my site:
    http://www.westhartfordfence.com/newsite/

    When you get down to the mobile view you can tap on "Menu" but you can't dive any deeper. Tap on "Fence & Gates" does nothing. Tap on "FAQ" and that will work because you're not diving into the navigation tree anymore, you're actually going to the FAQ page.


    2. Home Page Slider Not Working
    The slider on the home page has 4 images. They are all stacked on top of each other. This is obviously not how it's supposed to work. When I am logged into my CMS, the slider works perfectly. I've published the page numerous times so that's not the issue.

    Any help would be greatly appreciated.

  2. #2
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,225
    Mentioned
    51 Post(s)
    Tagged
    2 Thread(s)
    According to the validator, there are at least 7 duplicated IDs. I don't know if this is part of the problem, but there are none on the good site.

    A place to start.

  3. #3
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    39,803
    Mentioned
    158 Post(s)
    Tagged
    4 Thread(s)
    Quote Originally Posted by keithck73 View Post
    I

    2. Home Page Slider Not Working
    The slider on the home page has 4 images. They are all stacked on top of each other. This is obviously not how it's supposed to work. When I am logged into my CMS, the slider works perfectly. I've published the page numerous times so that's not the issue.

    Any help would be greatly appreciated.
    Where's the link to jquery as it seems to be missing. The slider needs the jquery library to function.

    Code:
    <script src="http://code.jquery.com/jquery-latest.min.js"></script>

  4. #4
    SitePoint Enthusiast
    Join Date
    Aug 2008
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the replies. I've fixed #s 2. I followed the advice on this post and that affected jquery.

    #1 Don't use jQuery? Don't load it!
    http://www.concrete5.org/documentati...pers/five-easy...

    Once I removed this "fix", that issue disappeared.

    Now on to #1.

    ronpat - Not sure how you did the validation but if you do it now, how many duplicate IDs are there?

  5. #5
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,225
    Mentioned
    51 Post(s)
    Tagged
    2 Thread(s)
    Quote Originally Posted by keithck73 View Post
    Thanks for the replies. I've fixed #s 2. I followed the advice on this post and that affected jquery.

    #1 Don't use jQuery? Don't load it!
    http://www.concrete5.org/documentati...pers/five-easy...

    Once I removed this "fix", that issue disappeared.

    Now on to #1.

    ronpat - Not sure how you did the validation but if you do it now, how many duplicate IDs are there?
    Which URL should I be looking at, please?
    http://www.concrete5.org/documentati...pers/five-easy (which seems to be a 404 page)
    or
    http://www.westhartfordfence.com/newsite/

    Which browser do you use? Most have dev tools built in. I use Firefox most of the time with the FireBug plug-in. When you Show Source, it uses the W3C validator and shows the results in a *friendlier* format at the bottom of the page.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •