I am trying to create a new database, which will *naturally* be relational, and so therefore will require Foreign Keys etc..

I see that phpMyAdmin is primitive enough not to support Foreign Keys relationships properly etc. unless it's specially configured to do so.

I've just spent the last hour going through the documentation; and
-- CREATED the 'phpmyadmin' database and all its necessary tables;
-- APPLIED the configuration changes to {config.inc.php}; and
-- then stopped/restarted Apache. (even rebooted since!)
AND IT STILL DOESN'T WORK!

I am connecting to my localserver database, using the 'root' user id; so I
take it I shouldn't have a security problem. So what *IS* my problem with this??

The lines in {config.inc.php} I changed are:-
----------------------------------------------------------------
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'PMA_bookmark';
$cfg['Servers'][$i]['relation'] = 'PMA_relation';
$cfg['Servers'][$i]['table_info'] = 'PMA_table_info';
$cfg['Servers'][$i]['table_coords'] = 'PMA_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'PMA_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'PMA_column_info';
$cfg['Servers'][$i]['history'] = 'PMA_history';
----------------------------------------------------------------

** BUT --- IT STILL DOESN'T WORK **

Anybody know why?


I am getting the following error details:-
----------------------------------------------------------------
$cfg['Servers'][$i]['pmadb'] ... OK

$cfg['Servers'][$i]['relation'] ... not OK [ Documentation ]
General relation features: Disabled

$cfg['Servers'][$i]['table_info'] ... not OK [ Documentation ]
Display Features: Disabled

$cfg['Servers'][$i]['table_coords'] ... not OK [ Documentation ]
$cfg['Servers'][$i]['pdf_pages'] ... not OK [ Documentation ]
Creation of PDFs: Disabled

$cfg['Servers'][$i]['column_info'] ... not OK [ Documentation ]
Displaying Column Comments: Disabled
Bookmarked SQL-query: Disabled
MIME ... not OK [ Documentation ]
$cfg['Servers'][$i]['history'] ... not OK [ Documentation ]
SQL-history: Disabled
----------------------------------------------------------------

PS: All the tables have been created in the {phpMyAdmin} database by 'root', and I am using 'root' for all access (locally).