SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Evangelist hantaah's Avatar
    Join Date
    Jul 2011
    Location
    Birmingham, Uk
    Posts
    562
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    php error for transfer

    Hi

    I backed up and saved all my data from a site. Extracted it all the the transfered all those files onto the new site ( root directory )
    All should be working fine but I have this error:


    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /home/muscom/public_html/index.php on line 17

    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /home/muscom/public_html/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required './wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/muscom/public_html/index.php on line 17

    What's the problem here and how can I fix it?

  2. #2
    SitePoint Mentor silver trophy
    Rubble's Avatar
    Join Date
    Dec 2005
    Location
    Cambridge, England
    Posts
    2,395
    Mentioned
    81 Post(s)
    Tagged
    3 Thread(s)
    It seems straight forward - you do not have the wp-blog-header.php file in the correct place!

    I do not use wordpress but I would have thought you need to install it and not just copy it from one sever to another. I would try installing a fresh version of wordpress and see if that works; you could probably then overwrite the site with your old files as long as it is the same version.

  3. #3
    SitePoint Evangelist hantaah's Avatar
    Join Date
    Jul 2011
    Location
    Birmingham, Uk
    Posts
    562
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Rubble View Post
    It seems straight forward - you do not have the wp-blog-header.php file in the correct place!

    I do not use wordpress but I would have thought you need to install it and not just copy it from one sever to another. I would try installing a fresh version of wordpress and see if that works; you could probably then overwrite the site with your old files as long as it is the same version.
    I can be done that way but I have done a complete back up of the wordpress and the database. I have imported the data base and all the wordpress files included. It should be working at this point for me to go ahead and replace urls etc but this error should no be there


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •