SitePoint Sponsor

User Tag List

Results 1 to 10 of 10
  1. #1
    SitePoint Guru
    Join Date
    Oct 2010
    Location
    Portland, Or
    Posts
    734
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Unable to shut off apache

    I have been working w/the sendmail.ini & php.ini so I can see about sending test emails when working on my sandbox in localhost.
    I need to shut off apache per the instructions. but when i try to shut it off I get the error message in the image attached.
    Also unable to keep mercurey open, but i think that could be because of a firewall.
    any advice please?
    thx
    DapacheError01.jpg

  2. #2
    SitePoint Zealot moretea's Avatar
    Join Date
    Jun 2004
    Location
    Texas, USA
    Posts
    118
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    The obvious question: have you tried killing it in Task Manager? If you are running it as a service, it would show up on the Processes tab of Task Manager (I think).

  3. #3
    I solve practical problems. bronze trophy
    Michael Morris's Avatar
    Join Date
    Jan 2008
    Location
    Knoxville TN
    Posts
    2,036
    Mentioned
    65 Post(s)
    Tagged
    0 Thread(s)
    Xampp has an install as service bat for both mysql and windows. I recommend running Apache and Mysql that way because the OS services manager is much more stable than XAMPP's control panel. Also, once they are installed as a service you won't need the XAMPP control panel.

    To open the services panel Start > Run> then type "services" at the prompt. (The full name of the program with extension is services.msc)

  4. #4
    SitePoint Guru
    Join Date
    Oct 2010
    Location
    Portland, Or
    Posts
    734
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    apacheError02.jpg
    Moretea. I evidently had not thought of the obvious. So thank you for suggesting it. However that also doesn't work. See attached image.
    Mike thank you for the advice that is actually the first I heard of that. Will give it a try.
    d

  5. #5
    SitePoint Guru
    Join Date
    Oct 2010
    Location
    Portland, Or
    Posts
    734
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    also a bit confuse about these error messages when the ports have not been changed, & not sure how to get
    "You are not running with administrator rights! This will work for
    1:22:37 PM [main] most application stuff but whenever you do something with services
    1:22:37 PM [main] there will be a security dialogue or things will break! So think
    1:22:37 PM [main] about running this application with administrator rights!
    "
    how can I fix this? i went to localhost/xampp. my permissions there seem ok.

    Thx
    DapacheError03.jpg

  6. #6
    SitePoint Guru
    Join Date
    Oct 2010
    Location
    Portland, Or
    Posts
    734
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    and found this as well
    "The error message says that the problem is with socket 3306's access permissions. Its probably blocked by your firewall

    What shows in XAMPP Control Panel? Two green 'running' lights for Apache & MySQL, or nothing?

    We also need a look in Windows Control Panel > Windows Firewall or whatever AV/Firewall tool you have - Make sure there are exceptions for these programs:
    httpd
    mysqd

    or

    c:\xampp\apache\bin\httpd.exe
    c:\xampp\mysql\bin\mysqld,exe

    You should be able to find their paths, through edit or properties. If they aren't there you can add them manually. "
    added the last two manually. but I think the issue persists.

  7. #7
    SitePoint Guru
    Join Date
    Nov 2003
    Location
    Huntsville AL
    Posts
    689
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Look on the back of your computer. There should be a switch labeled "Power". Switch it to the off position. Can pretty much guarantee that apache will shut down.

  8. #8
    SitePoint Guru
    Join Date
    Oct 2010
    Location
    Portland, Or
    Posts
    734
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    ahundiak while your answer is a bit patronizing and condescending (although perhaps very funny to you...) I had actually already tried it hoping that when i restarted it the new settings would be applied.
    they have not.

  9. #9
    SitePoint Guru
    Join Date
    Nov 2003
    Location
    Huntsville AL
    Posts
    689
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by pdxSherpa View Post
    ahundiak while your answer is a bit patronizing and condescending (although perhaps very funny to you...) I had actually already tried it hoping that when i restarted it the new settings would be applied.
    they have not.
    But I did answer your question. All seriousness aside, you are running xampp 3.1. I recently rebuilt a machine and it is running 3.2. I'd suggest removing your xampp directory and then installing the latest and greatest. Then go one step at a time and and reconfigure, testing the shutdown/startup as you go along. The xampp control panel works fine for me during configuration.

    P.S. I also have a fool proof method for ridding pets of fleas. It does however involve an incinerator.

  10. #10
    SitePoint Enthusiast scout1idf's Avatar
    Join Date
    Nov 2009
    Location
    Ohio
    Posts
    83
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Personally, I use EASYPHP. It can be installed on your computer or on a flash/external drive for portability. (mine's on a flash drive)


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •