SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Enthusiast mira's Avatar
    Join Date
    Jul 2003
    Location
    Des Moines
    Posts
    57
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Help needed desperatly

    Hi,
    I have installed IIS (XP pro) and Php and MySql ! I believe correctly.
    The trouble I am having The Book from Kevin Jank is a bit scetchy how to get to view the page and the Php commands displayed!!!
    I can see all the html code in my Browser but there it stops.
    I want to see and make sure every thing is working.
    Your help is very much appreciated. I am ready to trow in the towel.
    Ernst

  2. #2
    SitePoint Wizard bronze trophy
    Join Date
    Apr 2003
    Posts
    4,095
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This thread should be moved to the PHP forum.

  3. #3
    Employed Again Viflux's Avatar
    Join Date
    May 2003
    Location
    London, On.
    Posts
    1,130
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    When you load the page in your browser, you will never see the PHP code. It is parsed before being sent to the browser, so all you can see is the output. Which is a good thing

    To test if your php is working, create a file called "test.php" or something and include the line
    PHP Code:
    <?php phpinfo(); ?>
    It should output a bunch of details about your configuration.

  4. #4
    SitePoint Wizard bronze trophy
    Join Date
    Apr 2003
    Posts
    4,095
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Right.

  5. #5
    SitePoint Enthusiast mira's Avatar
    Join Date
    Jul 2003
    Location
    Des Moines
    Posts
    57
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks I keep this in mine!!!
    But I think that my Php is not correctly installed.
    Steven Janks Book: Page 7 Paragraph 2
    In the tree view, expand the entry labelled "local computer"........Default Web site choose "Properies"
    Click on "ISAPI" Filter .. Add PhP (OK)
    in the Exeutable field browse for the file "php4isapi.dll"
    in the "sapi" folder It should read (c:\PHP\sapi\php4isapi ) It does not read it this way it reads c:\PHP\php-4.3.2-Win32\sapi\php4isapi.dll
    click OK (OK) ??
    Then Click on Home directory tab and click "configuration".. Button - Mappings tab click add
    choose "php4isapi.dll" as executeable and PHP in File extension
    Here,- I got a Problem - I am unable to browse to the file and what ever I do I never can click on the "OK" button. It remains greyed out.
    What in the World did I do wrong?
    I been trying to slve this problem for the past 3 days.
    8 hours per day at least.
    I really appreciate your help
    Ernst

  6. #6
    SitePoint Enthusiast mira's Avatar
    Join Date
    Jul 2003
    Location
    Des Moines
    Posts
    57
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    OK Who and how can move this Thread?
    Ernst

  7. #7
    SitePoint Wizard bronze trophy
    Join Date
    Apr 2003
    Posts
    4,095
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I can't, but a SitePoint advisor could.

  8. #8
    SitePoint Member cybersunil's Avatar
    Join Date
    Apr 2003
    Location
    Mumbai
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,
    I hope you could try this.Forget IIS.
    Try this piece of software called phpdev.
    It has php and mysql configured and you can download it from www.firepages.com.au
    Hope this helps
    Take it easy and life will take you places


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •