SitePoint Sponsor

User Tag List

Results 1 to 10 of 10
  1. #1
    SitePoint Guru
    Join Date
    Oct 2010
    Location
    Portland, Or
    Posts
    724
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    had to reinstall xampp - cant start apache

    Was getting a controluser error. re installed xampp on win7 using the latest installer.
    now i can't start apache. I can't find where to change the port. and have only one old file in the older folder i renamed from xampp to "asdf">"mysqul" "bin" mysqld.exe that I can't remove. says it is open & in use but I closed everything restrted the pc and checked control manager.
    Could I get some advice on how to solve this please?
    thankyou
    Dapache01.jpg

  2. #2
    Hosting Team Leader silver trophybronze trophy
    cpradio's Avatar
    Join Date
    Jun 2002
    Location
    Ohio
    Posts
    5,054
    Mentioned
    152 Post(s)
    Tagged
    0 Thread(s)
    Do you have skype installed?

    The reason I ask, it uses port 443 (if I recall correctly) and that may be blocking your apache from starting. You can change it somewhere in the settings of skype to use a different port, but I don't quite remember where that setting is.
    Be sure to congratulate Patche on earning July's Member of the Month
    Go ahead and blame me, I still won't lose any sleep over it
    My Blog | My Technical Notes

  3. #3
    SitePoint Guru
    Join Date
    Oct 2010
    Location
    Portland, Or
    Posts
    724
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    cp it looks like i have it. but it is not installed.

  4. #4
    SitePoint Guru
    Join Date
    Oct 2010
    Location
    Portland, Or
    Posts
    724
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    k great.
    tried a system restore & now went from the blue screen of near death to start up repair....this blows!

  5. #5
    SitePoint Wizard
    Join Date
    Oct 2005
    Posts
    1,832
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    I had a few problems getting XAMPP running on Windows 7. If my memory serves, I had to right-click on the menu item or on the control panel file and choose to "run as administrator". Then I think I had to go into my anti-virus/firewall software and allow it to communicate. After that it worked fine.

  6. #6
    SitePoint Guru
    Join Date
    Oct 2010
    Location
    Portland, Or
    Posts
    724
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    k it was kinda hairy but my laptop is up & about again (even got to see the breaking bad finale.great!) now getting back to check out xampp. i got a slightly diff ui. not sure if it is because it is the newer version or issues?
    Does anyone else have this set up, w/all those question marks? Just created a database & so far no error msgs.xampp02.jpg
    D

  7. #7
    SitePoint Guru
    Join Date
    Oct 2010
    Location
    Portland, Or
    Posts
    724
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    phpMyAdmin01.jpg
    ok awesome. looks like xampp installed ok both apache & mysql are ok.
    Also installed wp again for local testing.
    but as you can see in the image i get the red exclamation marks & the message
    "Your configuration file contains settings (root with no password) that correspond to the default MySQL privileged account. Your MySQL server is running with this default, is open to intrusion, and you really should fix this security hole by setting a password for user 'root'."
    where is that configuration file???
    thx
    D

  8. #8
    From space with love silver trophy
    SpacePhoenix's Avatar
    Join Date
    May 2007
    Location
    Poole, UK
    Posts
    4,994
    Mentioned
    100 Post(s)
    Tagged
    0 Thread(s)
    Are all you tables of all your databases intact?

    Has each web app's database user been recreated (each limited to just that own app's database)?

    Have you created a new "super-user" for doing general work on the server (across all databases), which should be used instead of root?
    Community Team Advisor
    Forum Guidelines: Posting FAQ Signatures FAQ Self Promotion FAQ
    Help the Mods: What's Fluff? Report Fluff/Spam to a Moderator

  9. #9
    SitePoint Guru
    Join Date
    Oct 2010
    Location
    Portland, Or
    Posts
    724
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Hello Space:
    As for one & two, actually din't worry about all the old databases. they were just test db and i was ok removing all of them. I was more worried that something was wrong & i would not be able to use or create new dbs

    Using root as a super user for now. didn't think it would be necessary to add a new one. Did on the previous install.

    But as for my previous messages. are the exclamation marks just part of the new UI & not a concern.
    For the password warning. Not sure if they are referring to a file or the setting for user's privileges.

    thx all
    D

  10. #10
    Hosting Team Leader silver trophybronze trophy
    cpradio's Avatar
    Join Date
    Jun 2002
    Location
    Ohio
    Posts
    5,054
    Mentioned
    152 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by pdxSherpa View Post
    But as for my previous messages. are the exclamation marks just part of the new UI & not a concern.
    For the password warning. Not sure if they are referring to a file or the setting for user's privileges.
    If you open the control panel for xampp/wamp, you should see a button that takes you to the config for phpmyadmin under the Config button for Apache.
    There are fields in there for username and passwords.

    To update the root username, I had to do the following:
    1) Update the phpMyAdmin to use an auth_type of 'cookie' instead of config.

    Login to phpMyAdmin using root and no password
    Click on the Change Password
    Enter your new password for root
    Save it

    It should log you out if you try to go anywhere else. Login using your new password. The config message should have disappeared now.
    Be sure to congratulate Patche on earning July's Member of the Month
    Go ahead and blame me, I still won't lose any sleep over it
    My Blog | My Technical Notes


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •