SitePoint Sponsor

User Tag List

Results 1 to 12 of 12
  1. #1
    SitePoint Wizard
    Join Date
    May 2012
    Posts
    1,093
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Post can i install xampp and wampserver in same machine ?

    Hi I just want to ask, Is it possible to install xampp and wampserver in same machine or in one computer?...


    Thank you in advance

  2. #2
    Community Advisor bronze trophy
    fretburner's Avatar
    Join Date
    Apr 2013
    Location
    Brazil
    Posts
    1,388
    Mentioned
    45 Post(s)
    Tagged
    12 Thread(s)
    Hi jemz,

    Yes you can, although you couldn't run them both at the same time unless you changed the apache/mysql ports on one to prevent them conflicting. Having said that, I can't see any advantage to running both.

  3. #3
    SitePoint Wizard
    Join Date
    May 2012
    Posts
    1,093
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hi fretburner,

    Thank you for the quick reply....Okay i will just run them one at a time ,example if i want to run my project under the xampp so i will just run the xampp,and then when i want to run other project that is in the wampserver i should exit first the xampp to prevent conflict...am i right?


  4. #4
    Community Advisor bronze trophy
    fretburner's Avatar
    Join Date
    Apr 2013
    Location
    Brazil
    Posts
    1,388
    Mentioned
    45 Post(s)
    Tagged
    12 Thread(s)
    Sure, you can do.. but you know you can run multiple projects on a single server, right? You can set up virtual hosts so that you can have http://project1.localhost, http://project2.localhost, etc.

  5. #5
    SitePoint Member hostripples's Avatar
    Join Date
    Sep 2013
    Posts
    16
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes you can Install wamp and xampp on same machine .

    basically the trick is to change the port for the wamp apache server and mysql , by default apache listen on port 80 for browsers and mysql listen for port 3306

    you need to change the port number for apache. now this thing requires two small changes in a file which is http.conf

    this file is on two locations in wamp. one in apache location "C:\wamp\bin\apache\apache*.*.**\conf" where stars are basically the version number. open the file in any editor or notepad and search for this "Listen 80" and change it with "Listen 9090" that means now your server will listen on port number 9090 instead of default port.

    the another line is also in the same file just search for this line "ServerName localhost:80" and replace it with "ServerName localhost:9090"


    Now change the port for mysql

    now this is the second most important part. if you don't do this you will be accessing the xampp mysql interface and engine which will make you confuse if you don't know about it because then you will be thinking of adding your scripts in wamp so technically all the databases should be in the wamp as well but in reality the xampp server will take preference if xampp is already running and port is used from the xampp mysql. The wamp mysql will not start entirely and you will also get no problem with that because using the url "localhost/phpmyadmin/" will show the xampp phpmyadmin so to tackle this problem you have to change the mysql port to another number.

    To do that you have to go the mysql location which is in my machine is like this "C:\wamp\bin\mysql\mysql5.5.24". open the file "my.ini" and find the line

    port = 3306 and replace it with port = 3307

    this will enable your wamp mysql to access along with xampp mysql due to different port address.

    last part is to access the wamp mysql from wamp phpmyadmin interface. whenever you try to access phpmyadmin you will be seeing the xampp server or the one which is started first

    to tackel that problem we need to make a small change in another area which is phpmyadmin interface code.

    to do that go the location "C:\wamp\apps\phpmyadmin3.5.1" now phpmyadmin3.5.1 may be different according to your version but the things will be pretty much the same so to fix that problem find the file "config.inc.php"

    find these two lines

    $cfg['Servers'][$i]['verbose'] = 'localhost:3306'

    ;$cfg['Servers'][$i]['host'] = 'localhost:3306';

    and replace them with

    $cfg['Servers'][$i]['verbose'] = 'localhost:3307';

    $cfg['Servers'][$i]['host'] = 'localhost:3307';

    It is possible that you see these lines below

    $cfg['Servers'][$i]['verbose'] = 'localhost';

    $cfg['Servers'][$i]['host'] = 'localhost';

    so still replace them with lines below

    $cfg['Servers'][$i]['verbose'] = 'localhost:3307';

    $cfg['Servers'][$i]['host'] = 'localhost:3307';

    now when you access the phpmyadmin with wamp you will be accessing the wamp mysql engine

    e.g if now we use the following url "localhost:9090/phpmyadmin/" you will access the wamp mysql along with wamp server

    to access wamp server use "localhost:9090/"

    and for database connection string you have to use localhost:3307 for all your script from wordpress, joomla to magento
    Last edited by Mittineague; Sep 28, 2013 at 13:01. Reason: Please wait until you get your signature for your links.

  6. #6
    SitePoint Wizard
    Join Date
    May 2012
    Posts
    1,093
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by hostripples View Post
    Yes you can Install wamp and xampp on same machine .

    basically the trick is to change the port for the wamp apache server and mysql , by default apache listen on port 80 for browsers and mysql listen for port 3306

    you need to change the port number for apache. now this thing requires two small changes in a file which is http.conf

    this file is on two locations in wamp. one in apache location "C:\wamp\bin\apache\apache*.*.**\conf" where stars are basically the version number. open the file in any editor or notepad and search for this "Listen 80" and change it with "Listen 9090" that means now your server will listen on port number 9090 instead of default port.

    the another line is also in the same file just search for this line "ServerName localhost:80" and replace it with "ServerName localhost:9090"


    Now change the port for mysql

    now this is the second most important part. if you don't do this you will be accessing the xampp mysql interface and engine which will make you confuse if you don't know about it because then you will be thinking of adding your scripts in wamp so technically all the databases should be in the wamp as well but in reality the xampp server will take preference if xampp is already running and port is used from the xampp mysql. The wamp mysql will not start entirely and you will also get no problem with that because using the url "localhost/phpmyadmin/" will show the xampp phpmyadmin so to tackle this problem you have to change the mysql port to another number.

    To do that you have to go the mysql location which is in my machine is like this "C:\wamp\bin\mysql\mysql5.5.24". open the file "my.ini" and find the line

    port = 3306 and replace it with port = 3307

    this will enable your wamp mysql to access along with xampp mysql due to different port address.

    last part is to access the wamp mysql from wamp phpmyadmin interface. whenever you try to access phpmyadmin you will be seeing the xampp server or the one which is started first

    to tackel that problem we need to make a small change in another area which is phpmyadmin interface code.

    to do that go the location "C:\wamp\apps\phpmyadmin3.5.1" now phpmyadmin3.5.1 may be different according to your version but the things will be pretty much the same so to fix that problem find the file "config.inc.php"

    find these two lines

    $cfg['Servers'][$i]['verbose'] = 'localhost:3306'

    ;$cfg['Servers'][$i]['host'] = 'localhost:3306';

    and replace them with

    $cfg['Servers'][$i]['verbose'] = 'localhost:3307';

    $cfg['Servers'][$i]['host'] = 'localhost:3307';

    It is possible that you see these lines below

    $cfg['Servers'][$i]['verbose'] = 'localhost';

    $cfg['Servers'][$i]['host'] = 'localhost';

    so still replace them with lines below

    $cfg['Servers'][$i]['verbose'] = 'localhost:3307';

    $cfg['Servers'][$i]['host'] = 'localhost:3307';

    now when you access the phpmyadmin with wamp you will be accessing the wamp mysql engine

    e.g if now we use the following url "localhost:9090/phpmyadmin/" you will access the wamp mysql along with wamp server

    to access wamp server use "localhost:9090/"

    and for database connection string you have to use localhost:3307 for all your script from wordpress, joomla to magento

    Hi sorry for the late reply... wow this is very detailed. okay i will let you know if this works for me.Thank you so much.

  7. #7
    SitePoint Wizard
    Join Date
    May 2012
    Posts
    1,093
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hi it's working, Thank you so much

    Quote Originally Posted by hostripples View Post
    Yes you can Install wamp and xampp on same machine .

    basically the trick is to change the port for the wamp apache server and mysql , by default apache listen on port 80 for browsers and mysql listen for port 3306

    you need to change the port number for apache. now this thing requires two small changes in a file which is http.conf

    this file is on two locations in wamp. one in apache location "C:\wamp\bin\apache\apache*.*.**\conf" where stars are basically the version number. open the file in any editor or notepad and search for this "Listen 80" and change it with "Listen 9090" that means now your server will listen on port number 9090 instead of default port.

    the another line is also in the same file just search for this line "ServerName localhost:80" and replace it with "ServerName localhost:9090"


    Now change the port for mysql

    now this is the second most important part. if you don't do this you will be accessing the xampp mysql interface and engine which will make you confuse if you don't know about it because then you will be thinking of adding your scripts in wamp so technically all the databases should be in the wamp as well but in reality the xampp server will take preference if xampp is already running and port is used from the xampp mysql. The wamp mysql will not start entirely and you will also get no problem with that because using the url "localhost/phpmyadmin/" will show the xampp phpmyadmin so to tackle this problem you have to change the mysql port to another number.

    To do that you have to go the mysql location which is in my machine is like this "C:\wamp\bin\mysql\mysql5.5.24". open the file "my.ini" and find the line

    port = 3306 and replace it with port = 3307

    this will enable your wamp mysql to access along with xampp mysql due to different port address.

    last part is to access the wamp mysql from wamp phpmyadmin interface. whenever you try to access phpmyadmin you will be seeing the xampp server or the one which is started first

    to tackel that problem we need to make a small change in another area which is phpmyadmin interface code.

    to do that go the location "C:\wamp\apps\phpmyadmin3.5.1" now phpmyadmin3.5.1 may be different according to your version but the things will be pretty much the same so to fix that problem find the file "config.inc.php"

    find these two lines

    $cfg['Servers'][$i]['verbose'] = 'localhost:3306'

    ;$cfg['Servers'][$i]['host'] = 'localhost:3306';

    and replace them with

    $cfg['Servers'][$i]['verbose'] = 'localhost:3307';

    $cfg['Servers'][$i]['host'] = 'localhost:3307';

    It is possible that you see these lines below

    $cfg['Servers'][$i]['verbose'] = 'localhost';

    $cfg['Servers'][$i]['host'] = 'localhost';

    so still replace them with lines below

    $cfg['Servers'][$i]['verbose'] = 'localhost:3307';

    $cfg['Servers'][$i]['host'] = 'localhost:3307';

    now when you access the phpmyadmin with wamp you will be accessing the wamp mysql engine

    e.g if now we use the following url "localhost:9090/phpmyadmin/" you will access the wamp mysql along with wamp server

    to access wamp server use "localhost:9090/"

    and for database connection string you have to use localhost:3307 for all your script from wordpress, joomla to magento

  8. #8
    SitePoint Wizard
    Join Date
    May 2012
    Posts
    1,093
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hi hosttriples, I have some problem in accessing the phpmyadmin in wampserver

    #2002 - No connection could be made because the target machine actively refused it.
    I followed your steps.

  9. #9
    SitePoint Wizard
    Join Date
    May 2012
    Posts
    1,093
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hi hosttriples, It's okay now i replace all the lines port 3306 with 3307...

  10. #10
    SitePoint Wizard
    Join Date
    May 2012
    Posts
    1,093
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hi, I can't navigate to the page using this http://localhost:9090/test/mysite

  11. #11
    SitePoint Wizard
    Join Date
    May 2012
    Posts
    1,093
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hi sorry for my post again...it's working again i missed this line
    $cfg['Servers'][$i]['port'] = '';
    it's empty so i added 3307
    it would be like this
    $cfg['Servers'][$i]['port'] = '3307';
    and it's working now...i'll be back if i get in trouble.

  12. #12
    SitePoint Member hostripples's Avatar
    Join Date
    Sep 2013
    Posts
    16
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by jemz View Post
    Hi sorry for my post again...it's working again i missed this line it's empty so i added 3307
    it would be like this and it's working now...i'll be back if i get in trouble.
    Hello jemz,

    Its good to see that your issue has been resolved .


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •