SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    Jul 2003
    Location
    NJ
    Posts
    42
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE 5.x box fix works on one page, not on other one: same stylesheet used

    What's up?

    I am designing a site with CSS as the layout mechanism. I used the special hack to get around the IE 5.x box problem. Currently, I am testing it on IE 6 but I have seen it work on 5.x browsers.

    Now, I created a different page with the same exact stylesheet linked. However, the new page is following the adjusted width and code for the IE 5.x browser. They are the same exact style sheets and same testing browser!

    If I take out the IE 5.x hack in the CSS, it fixes the layout in the non-working page. I'm stumped . . .

    Here is a link to the correct view page test.html:

    http://www.pinemind.com/test.html

    Here is a link to the one which is not displaying properly:

    http://www.pinemind.com/news.php

    ps. don't mind the fact that the mysql thing is not working, that's my next problem.

    Also, here is the css code for the top, left and leftbox divs:
    Code:
    #top {
    	margin: 20px 0px 0px 0px;
    	padding: 10px 0px 10px 0px;
    	border-width: 2px 0px 2px 0px;
    	border-style: solid;
    	border-color: #336600;
    	background-color: inherit;
    	background-image: url(../pmlogo2smalla.gif);
    	background-repeat: no-repeat;
    	height: 70px; /* ie5win fudge begins */
    	voice-family: "\"}\"";
    	voice-family:inherit;
    	height: 46px;
    	
    	
    	}
    html>body #top {
    	height: 46px; /* ie5win fudge ends */
    	}
    #left {
    	position: absolute;
    	top: 90px;
    	left: 18px;
    	margin: 0px 0px 0px 0px;
    	padding: 10px 10px 10px 10px;
    	border-width: 0px 0px 0px 2px; 
    	border-style: solid;
    	border-color: #336600;
    	background: #fff;
    	width: 150px; /* ie5win fudge begins */
    	voice-family: "\"}\"";
    	voice-family:inherit;
    	width: 124px;
    	}
    html>body #left {
    	width: 124px; /* ie5win fudge ends */
    	}
    
    #leftbox {
    	position:relative;
    	padding: 10px 9px 10px 10px;
    	margin: 10px 0px 0px 0px;
    	border: 2px;
    	border-style: solid; 
    	border-color: #336600;
    	background: #FFF;
    	width: 150px; /* ie5win fudge begins */
    	voice-family: "\"}\"";
    	voice-family:inherit;
    	width: 124px;
    	}
    html>body #leftbox {
    	width: 124px; /* ie5win fudge ends */
    	}
    
    #middle {
    	margin: 10px 20px 20px 189px;
    	padding: 10px;
    	border-width: 2px 2px 2px 2px;
    	border-style: solid;
    	border-color: #336600;
    	background: #fff;
    	}


    Please help me out!

    Justin

  2. #2
    SitePoint Wizard silver trophy Crazybanana's Avatar
    Join Date
    Mar 2003
    Location
    In tha fruit cellar
    Posts
    1,379
    Mentioned
    32 Post(s)
    Tagged
    1 Thread(s)
    if i got this right.. (im not sure i did) you think the boxes in the other pages doesnt display properly..
    your warning messages is wrote before the actual code of the page and pushes your logo and boxes down. get rid of those warnings and the page should display right. tested in ie 5.5.
    Who's to doom when the judge himself is dragged before the bar



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •