I am getting an error when trying to install dnode?? Any thoughts?

Code:
{
    "name": "nockmarket"
  , "version": "0.0.1"
  , "private": true
  , "dependencies": {
    "clone": "0.1.9"
    , "mocha": "1.3.0"
    , "should": "1.0.0"
    , "ejs" : "0.7.1"
    , "express": "2.5.8"
    , "mongodb": "1.0.2"
    , "dnode" : "1.0.0"
  }
}
Code:
D:\JumpStartNodeJs\nockmarket>npm install
npm WARN package.json nockmarket@0.0.1 No README.md file found!
npm http GET https://registry.npmjs.org/dnode/1.0.0
npm http 304 https://registry.npmjs.org/dnode/1.0.0
npm http GET https://registry.npmjs.org/dnode-protocol
npm http GET https://registry.npmjs.org/jsonify
npm http GET https://registry.npmjs.org/weak
npm http 304 https://registry.npmjs.org/jsonify
npm http 304 https://registry.npmjs.org/dnode-protocol
npm http 304 https://registry.npmjs.org/weak
npm http GET https://registry.npmjs.org/bindings
npm http GET https://registry.npmjs.org/traverse
npm http 304 https://registry.npmjs.org/bindings
npm http 304 https://registry.npmjs.org/traverse

> weak@0.2.2 install D:\JumpStartNodeJs\nockmarket\node_modules\dnode\node_modul
es\weak
> node-gyp rebuild


D:\JumpStartNodeJs\nockmarket\node_modules\dnode\node_modules\weak>node "C:\Dev\
nodejs\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-g
yp.js" rebuild
gyp ERR! configure error
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYT
HON env variable.
gyp ERR! stack     at failNoPython (C:\Dev\nodejs\node_modules\npm\node_modules\
node-gyp\lib\configure.js:113:14)
gyp ERR! stack     at C:\Dev\nodejs\node_modules\npm\node_modules\node-gyp\lib\c
onfigure.js:81:11
gyp ERR! stack     at Object.oncomplete (fs.js:107:15)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "node" "C:\\Dev\\nodejs\\node_modules\\npm\\node_modules\\node-
gyp\\bin\\node-gyp.js" "rebuild"
gyp ERR! cwd D:\JumpStartNodeJs\nockmarket\node_modules\dnode\node_modules\weak
gyp ERR! node -v v0.10.5
gyp ERR! node-gyp -v v0.9.5
gyp ERR! not ok
npm ERR! error rolling back Error: ENOTEMPTY, rmdir 'D:\JumpStartNodeJs\nockmark
et\node_modules\dnode\node_modules\dnode-protocol'
npm ERR! error rolling back  dnode@1.0.0 { [Error: ENOTEMPTY, rmdir 'D:\JumpStar
tNodeJs\nockmarket\node_modules\dnode\node_modules\dnode-protocol']
npm ERR! error rolling back   errno: 53,
npm ERR! error rolling back   code: 'ENOTEMPTY',
npm ERR! error rolling back   path: 'D:\\JumpStartNodeJs\\nockmarket\\node_modul
es\\dnode\\node_modules\\dnode-protocol' }
npm ERR! weak@0.2.2 install: `node-gyp rebuild`
npm ERR! `cmd "/c" "node-gyp rebuild"` failed with 1
npm ERR!
npm ERR! Failed at the weak@0.2.2 install script.
npm ERR! This is most likely a problem with the weak package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls weak
npm ERR! There is likely additional logging output above.

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "C:\\Dev\\nodejs\\\\node.exe" "C:\\Dev\\nodejs\\node_modules\\n
pm\\bin\\npm-cli.js" "install"
npm ERR! cwd D:\JumpStartNodeJs\nockmarket
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! code ELIFECYCLE
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     D:\JumpStartNodeJs\nockmarket\npm-debug.log
npm ERR! not ok code 0

D:\JumpStartNodeJs\nockmarket>