SitePoint Sponsor

User Tag List

Results 1 to 12 of 12

Thread: Menu Issues

  1. #1
    SitePoint Member
    Join Date
    Aug 2013
    Location
    FLorida
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Menu Issues

    I have a website called http://latinobaseball.com/ and I am having an menu issue. The menu works perfectly until I click on a choice inside galleria. Once I do this the menu goes behind the content. I was given a fix for this:

    div#top {z-index: 600000;position: relative;}

    Now the menu will show while inside galleria but when I go to hover over the drop-down the menu drop-down disappears.

    Any help with this would be greatly appreciated!

    Jeremy Lee

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,097
    Mentioned
    448 Post(s)
    Tagged
    8 Thread(s)
    Hi jeremy1128. Welcome to the forums.

    Now the menu will show while inside galleria but when I go to hover over the drop-down the menu drop-down disappears.
    I'm not seeing a problem. Could you clarify a bit? What browser are you using?
    Facebook | Google+ | Twitter | Web Design Tips | Free Contact Form

    Forum Usage: Tips on posting code samples, images and more

    Forrest Gump: "IE is like a box of chocolates: you never know what you're gonna get."

  3. #3
    SitePoint Member
    Join Date
    Aug 2013
    Location
    FLorida
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you for responding. If you click on a menu item inside Galeria, like HHD and once that page loads the menu will come up again, but you cannot click on the dop-down menu. The drop-down menu disappears on hover.

    This happens on Chrome, Fire-Fox IE 8 & 9.

    Thanks!

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,097
    Mentioned
    448 Post(s)
    Tagged
    8 Thread(s)
    The problem is that there's a gap between the top LI and the drop menu, so when the mouse moves off the top LI the hover effect breaks.

    Try changing the top setting here (on line 36 in one of your many style sheets):

    Code:
    .menutop li.root:hover > .fusion-submenu-wrapper {
    top: 65px;
    left: 0;
    }
    to this

    Code:
    .menutop li.root:hover > .fusion-submenu-wrapper {
    top: 100%;
    left: 0;
    }
    It's odd that you have different code applying on the home page from other pages.
    Facebook | Google+ | Twitter | Web Design Tips | Free Contact Form

    Forum Usage: Tips on posting code samples, images and more

    Forrest Gump: "IE is like a box of chocolates: you never know what you're gonna get."

  5. #5
    SitePoint Member
    Join Date
    Aug 2013
    Location
    FLorida
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you, could you tell me which css file this lives in?

    Thank you again for pointing this out!

  6. #6
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,456
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Those styles appear twice in your CSS stylesheet.
    http://latinobaseball.com/templates/...3f7c1f9ef2.php
    somewhere in lines 28 and 36

    Just add Ralph's code to the bottom of your local on-page styles. That *should* fix the problem by overriding the preceeding two instances.

  7. #7
    SitePoint Member
    Join Date
    Aug 2013
    Location
    FLorida
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Unfortunately that did not fix the problem. I went ahead and changed all instances of the 65px in all CSS files, cleared cache and still having the same issue. Sorry guys!

    Still looking for a solution as well.

    I did find that if I disabled the Simple Image Gallery in Galeria everything works perfectly. So something inside SIG is causing the problem. plugins/content/plugin_jw_sig

  8. #8
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,456
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    jeremy,

    According to FireBug, the style that is causing the problem is located here:
    http://latinobaseball.com/templates/...3f7c1f9ef2.php (line 36).
    Code:
    .menutop li.root:hover > .fusion-submenu-wrapper {
        left: 0;
        top: 65px;
    }
    It has not been overridden.

    If top:65px is deleted or changed to 100%, the menus behave correctly.

    I do not see Ralph's code in the css at the top of the local page, http://latinobaseball.com/


    Where in Florida do you live?

  9. #9
    SitePoint Member
    Join Date
    Aug 2013
    Location
    FLorida
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I will take a look again at the CSS your referring to. Thanks!

    I live in the Gainesville area which is 1.5 hours south of Jacksonville and and 1.5 hours north of Orlando.

  10. #10
    SitePoint Member
    Join Date
    Aug 2013
    Location
    FLorida
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    PERFECT! That worked... you guys are awesome! Thank you so much!

  11. #11
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,456
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    You're very welcome.

    I lived in Gainesville when I was a small child... through the 3rd grade. "Kirby Smith Elementary School", if it's still there.
    My family moved to Jacksonville afterwards. That was a long time ago. I'm sure I wouldn't recognize G'ville now.

    Cheers.

  12. #12
    SitePoint Member
    Join Date
    Aug 2013
    Location
    FLorida
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    That was a long time ago... Kirby is now the center for The School Board of Alachua County. It has changed a lot and yes Gainesville has changed tremendously in just the last 30 plus years that I have known it.

    Small world! Thanks again for your help! I truly do appreciate it!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •