SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Aug 2013
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CSS Menu drops behind LayerSlider

    Problem: My CSS Menu drops behind the LayerSlider slides.

    Info: On my own testing site on a different host, this does not happen. The only different between the sites are some of the general content as well as editing of the Z-Index AFTER the problem has occured. http://air2data.com/jake/ this is the staging area for new site. http://aeonstrife.com/air2data/ This is other host.

    My work has me building this site which is slightly out of my expertise and comfort zone. I have had some wordpress experience in the past, but have been self teaching myself lately. I can edit and read CSS HTML and Jscript from some classes at school so I can understand replies within that context and im really crappy with PHP, but Wordpress is all a messy jumble to me so you may have to tell me where certain files are I may have to edit if required.

    Referred to here by Rhys, said it was a good place. =) Thanks ahead of time for any help! Sometimes wordpress can be a pain.

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,207
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    Hi David. Welcome to the forums.

    All you need to do here is raise the z-index on the #header div. Any high value will do, but even 3 is enough (line 809):

    Code:
    #header {
    background-color: #1B1B1B;
    padding-top: 40px;
    position: relative;
    border-top: 5px solid #00BFF3;
    -webkit-box-shadow: 0 1px 1px rgba(0, 0, 0, 0.1);
    -moz-box-shadow: 0 1px 1px rgba(0,0,0,0.1);
    box-shadow: 0 1px 1px rgba(0, 0, 0, 0.1);
    z-index: 100;
    }

  3. #3
    SitePoint Member
    Join Date
    Aug 2013
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ralph,

    It worked! and well indeed =). I must also say that I have never on any forum received such a simple and working answer on the first reply.. ever haha. You have made my first experience here wonderful.

    Thanks, =)

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,207
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    That's great to know, David. We do try to be friendly and helpful.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •