SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Addict
    Join Date
    Sep 2009
    Posts
    316
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Jquery scrolling plugin not working in different browsers

    I'm in the early stages of troubleshooting and I'm wondering if anyone can point me in any direction to deduce the issue. I have a site with a scrolling plugin (JQuery Waypoints http://imakewebthings.com/jquery-waypoints/) implemented on the top navigation. Here's what's happening:

    1. The scroll functionality is working on Safari v.6.0.5 on one computer and not working on another computer with the same version.
    2. It's working in Chrome v.28.0.1500.71 on one computer and not working on another computer with the same version of the browser.

    The variables I can pinpoint so far are the Mac OS versions. The computer in which this scroll function works is OSX 10.7.5 and the other computer, where the scrolling functionality does not work, is 10.8.4.

    The other issue is the version of the plugin. I need to double check about which version is currently used - https://github.com/imakewebthings/jquery-waypoints


    Thanks in advance.

  2. #2
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    6,060
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    Sounds bizarre and I don't have a Mac to test on, but if you post the URL of your site, I can test it on Windows 8 with the big 5.

  3. #3
    SitePoint Addict
    Join Date
    Sep 2009
    Posts
    316
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Pullo View Post
    Sounds bizarre and I don't have a Mac to test on, but if you post the URL of your site, I can test it on Windows 8 with the big 5.

    This is the site: http://deviantartads.com/

  4. #4
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    6,060
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    Hi,

    On Windows 8, the scrolling on your site works as expected in the latest versions of Chrome, Opera, Safari, Firefox and IE 7 - 10.
    The page load time was pretty awful though, you might want to do something about that.

    HTH

  5. #5
    SitePoint Addict
    Join Date
    Sep 2009
    Posts
    316
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Pullo View Post
    Hi,

    On Windows 8, the scrolling on your site works as expected in the latest versions of Chrome, Opera, Safari, Firefox and IE 7 - 10.
    The page load time was pretty awful though, you might want to do something about that.

    HTH
    Yeah, I will go through and work on the load time. I'm aware. Thanks for checking. I'm baffled by the issue so far.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •