SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Jul 2013
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Different Presentation in Chrome and Firefox

    I am trying to design a website and while it functions perfectly on google chrome, there are a few issues when I try to use it on firefox. Firstly, the banner on the top of the page looks awful as it has expanded and shifted to the left. Also, the links to our pop up windows open up to a completely different version of the page that can be seen on chrome. In short, why are there differences between these browsers and how can I fix them?

  2. #2
    SitePoint Zealot moretea's Avatar
    Join Date
    Jun 2004
    Location
    Texas, USA
    Posts
    117
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Can you post the URL of the page, or the page code itself?

  3. #3
    SitePoint Member
    Join Date
    Jul 2013
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    http://www.solarnyc.com/workshops/

    This is the link to the site and the code is:

    <table width="100%" cellspacing="0" cellpadding="0">
    <tr>
    <td align="center" bgcolor="#656565" cellspacing="0" cellpadding="0" id="header">
    <div class="banner" align="center">
    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="987" id="index" align="bottom">
    <param name="allowScriptAccess" value="sameDomain" />
    <param name="movie" value="http://www.solarnyc.com/workshops/banner/banner12.swf" />
    <param name="quality" value="autohigh" />
    <param name="scale" value="noborder" />
    <param name="salign" value="rt" />
    <param name="bgcolor" value="#B8D3EB" />
    <embed src="http://www.solarnyc.com/workshops/banner/banner12.swf" quality="autohigh" scale="noborder" salign="rt" bgcolor="#B8D3EB" width="987" name="index" align="bottom" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
    </object>
    </div>

  4. #4
    SitePoint Zealot moretea's Avatar
    Join Date
    Jun 2004
    Location
    Texas, USA
    Posts
    117
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Sorry, I can't see that site from my current location. Perhaps someone else can troubleshoot?

  5. #5
    Programming Since 1978 silver trophybronze trophy felgall's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, NSW, Australia
    Posts
    16,603
    Mentioned
    24 Post(s)
    Tagged
    1 Thread(s)
    Why are you using an object that is IE6 specific instead of the more generic version without the classid that works for all more modern browsers?

    Also once you change the object to work for modern browsers you can then do away with the embed unless you still have lots of visitors using Netscape 4.

    I'd also recommend that you get rid of the HTML 3.2 attributes that were made obsolete back in 1997 - you will get more consistent results using CSS.
    Stephen J Chapman

    javascriptexample.net, Book Reviews, follow me on Twitter
    HTML Help, CSS Help, JavaScript Help, PHP/mySQL Help, blog
    <input name="html5" type="text" required pattern="^$">


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •