SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Thread: errno: 145

  1. #1
    SitePoint Zealot jsk137's Avatar
    Join Date
    Jan 2002
    Posts
    151
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    errno: 145

    I am getting this error:
    Can't open file: 'myTableName.MYI'. (errno: 145)
    All the other tables in this database and my other databases are working, just this one is failing.

    It is failing in my application (which has been working for months without problem) and is failing in PhpoMyAdmin also.

    I've also never seen the .MYI before.

    Do you know what the problem is? This is the first time I've had this happen.

    Jeff

  2. #2
    Mlle. Ledoyen silver trophy seanf's Avatar
    Join Date
    Jan 2001
    Location
    UK
    Posts
    7,168
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Your table is corrupt. More info and recovery instructions here

    Sean
    Harry Potter

    -- You lived inside my world so softly
    -- Protected only by the kindness of your nature

  3. #3
    SitePoint Zealot kamm's Avatar
    Join Date
    Nov 2003
    Location
    Espaņa
    Posts
    162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I had a this happen to me today (errno: 145).

    A small database that checks server load via cron every 5 minutes, gets dropped and recreated once a week.

    Repaired it OK, no big drama, but out of curiosity who knows what might cause a table to get corrupted?

    hasta later,
    kamm...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •