SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Jul 2013
    Location
    Houston
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Can't get Apache server up

    So, obviously I'm new to the forum. I apologize in advance if I'm doing things the wrong way. I was referred to this forum from a book I'm reading called "PHP & MySQL: Novice to Ninja". I'm trying to get into the web development world, figuring learning how to do this would be good for my resume.

    Things I've done:

    -Downloaded XAMPP Control Panel v3.2.1, which has MySQL and Apache as part of the package. I'm able to start MySQL with no issues, but Apache gives me an error... here's the log if you guys need it for some reason.

    4:29:09 PM [main] Initializing Control Panel
    4:29:09 PM [main] Windows Version: Windows 7 Ultimate SP1 64-bit
    4:29:09 PM [main] XAMPP Version: 1.8.2
    4:29:09 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
    4:29:09 PM [main] You are not running with administrator rights! This will work for
    4:29:09 PM [main] most application stuff but whenever you do something with services
    4:29:09 PM [main] there will be a security dialogue or things will break! So think
    4:29:09 PM [main] about running this application with administrator rights!
    4:29:09 PM [main] XAMPP Installation Directory: "c:\xampp\"
    4:29:09 PM [main] Checking for prerequisites
    4:31:29 PM [main] All prerequisites found
    4:31:29 PM [main] Initializing Modules
    4:31:29 PM [Apache] Problem detected!
    4:31:29 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
    4:31:29 PM [Apache] Apache WILL NOT start without the configured ports free!
    4:31:29 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
    4:31:29 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
    4:31:29 PM [main] Starting Check-Timer
    4:31:29 PM [main] Control Panel Ready
    4:31:41 PM [Apache] Problem detected!
    4:31:41 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
    4:31:41 PM [Apache] Apache WILL NOT start without the configured ports free!
    4:31:41 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
    4:31:41 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
    4:31:41 PM [Apache] Attempting to start Apache app...
    4:31:41 PM [Apache] Status change detected: running
    4:32:01 PM [Apache] Status change detected: stopped
    4:32:01 PM [Apache] Error: Apache shutdown unexpectedly.
    4:32:01 PM [Apache] This may be due to a blocked port, missing dependencies,
    4:32:01 PM [Apache] improper privileges, a crash, or a shutdown by another method.
    4:32:01 PM [Apache] Press the Logs button to view error logs and check
    4:32:01 PM [Apache] the Windows Event Viewer for more clues
    4:32:01 PM [Apache] If you need more help, copy and post this
    4:32:01 PM [Apache] entire log window on the forums

    Says the error is a result of a blocked port. The book suggests that the issue is probably because of a blocked port. I've tried uninstalling things that look like they might be web servers (and restarting the computer after each time), but so far I haven't found it. The book also suggests it might be firewall or virus scanner related. I temp disabled both for a little while and that didn't seem to fix it (perhaps I need to just flat out uninstall?). I'm running Norton for both my firewall and virus scanning needs. Running windows 7.

    I appreciate you guys being patient here. I've certainly been on the other side of the issue where some new poster comes in and immediately wants his problem solved without putting any effort into fixing it themselves. Again, if I'm going about this the wrong way, please let me know.

  2. #2
    SitePoint Member
    Join Date
    Jul 2013
    Location
    Houston
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Tried out port check...



    Says Apache is in port 80. So, I'm confused as to what is going on. I think if I can't find any other ideas, I'm just going to see if completely uninstalling and reinstalling everything will work.

  3. #3
    From space with love silver trophy
    SpacePhoenix's Avatar
    Join Date
    May 2007
    Location
    Poole, UK
    Posts
    5,014
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    Have you got Skype running at the same time? If you have set it to use a different port
    Community Team Advisor
    Forum Guidelines: Posting FAQ Signatures FAQ Self Promotion FAQ
    Help the Mods: What's Fluff? Report Fluff/Spam to a Moderator

  4. #4
    SitePoint Member
    Join Date
    Jul 2013
    Location
    Houston
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by SpacePhoenix View Post
    Have you got Skype running at the same time? If you have set it to use a different port
    I do not have Skype on my computer. I don't know if MSN or any of those messengers do something similar (probably not).

    My current theory is I have SQL Server 2008 loaded on there from when I was doing a project that needed that. I'm trying to uninstall that from my computer. I heard somewhere that perhaps one of the files automatically defaults to port 80.

  5. #5
    SitePoint Member
    Join Date
    Jul 2013
    Location
    Houston
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The SQL thing did it. I had one random SQL 2000 file on there (no clue when that happened, might've been from a botched attempt to get SQL 2000 on my computer). Uninstalled that... tried to run Apache, and it's running. MySQL is running as well. So, just in case someone else runs into the same issue, that's apparently something that can interfere with it.

  6. #6
    SitePoint Enthusiast Belsnickle's Avatar
    Join Date
    Feb 2012
    Location
    Chico, CA
    Posts
    68
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I know I'm fairly late to this topic but I've had and solved this issue twice on two Windows 8.1 machines in large part thanks to this bit of rarely provided information on this issue.

    Essentially Windows 8/8.1 machine have a service called ”World Wide Web Publishing Service” running by default that blocks apache from being able to run by default on XAMPP, if you disable it and set it to manual activation you should solve this issue if nothing else.

    It's also worth noting that port controls on the windows 8 skype app aren't easily accessible but, fortunately, are not something that contributes to the problem with the skype app as opposed to the desktop program.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •