So, obviously I'm new to the forum. I apologize in advance if I'm doing things the wrong way. I was referred to this forum from a book I'm reading called "PHP & MySQL: Novice to Ninja". I'm trying to get into the web development world, figuring learning how to do this would be good for my resume.

Things I've done:

-Downloaded XAMPP Control Panel v3.2.1, which has MySQL and Apache as part of the package. I'm able to start MySQL with no issues, but Apache gives me an error... here's the log if you guys need it for some reason.

4:29:09 PM [main] Initializing Control Panel
4:29:09 PM [main] Windows Version: Windows 7 Ultimate SP1 64-bit
4:29:09 PM [main] XAMPP Version: 1.8.2
4:29:09 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
4:29:09 PM [main] You are not running with administrator rights! This will work for
4:29:09 PM [main] most application stuff but whenever you do something with services
4:29:09 PM [main] there will be a security dialogue or things will break! So think
4:29:09 PM [main] about running this application with administrator rights!
4:29:09 PM [main] XAMPP Installation Directory: "c:\xampp\"
4:29:09 PM [main] Checking for prerequisites
4:31:29 PM [main] All prerequisites found
4:31:29 PM [main] Initializing Modules
4:31:29 PM [Apache] Problem detected!
4:31:29 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
4:31:29 PM [Apache] Apache WILL NOT start without the configured ports free!
4:31:29 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:31:29 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:31:29 PM [main] Starting Check-Timer
4:31:29 PM [main] Control Panel Ready
4:31:41 PM [Apache] Problem detected!
4:31:41 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
4:31:41 PM [Apache] Apache WILL NOT start without the configured ports free!
4:31:41 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:31:41 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:31:41 PM [Apache] Attempting to start Apache app...
4:31:41 PM [Apache] Status change detected: running
4:32:01 PM [Apache] Status change detected: stopped
4:32:01 PM [Apache] Error: Apache shutdown unexpectedly.
4:32:01 PM [Apache] This may be due to a blocked port, missing dependencies,
4:32:01 PM [Apache] improper privileges, a crash, or a shutdown by another method.
4:32:01 PM [Apache] Press the Logs button to view error logs and check
4:32:01 PM [Apache] the Windows Event Viewer for more clues
4:32:01 PM [Apache] If you need more help, copy and post this
4:32:01 PM [Apache] entire log window on the forums

Says the error is a result of a blocked port. The book suggests that the issue is probably because of a blocked port. I've tried uninstalling things that look like they might be web servers (and restarting the computer after each time), but so far I haven't found it. The book also suggests it might be firewall or virus scanner related. I temp disabled both for a little while and that didn't seem to fix it (perhaps I need to just flat out uninstall?). I'm running Norton for both my firewall and virus scanning needs. Running windows 7.

I appreciate you guys being patient here. I've certainly been on the other side of the issue where some new poster comes in and immediately wants his problem solved without putting any effort into fixing it themselves. Again, if I'm going about this the wrong way, please let me know.