SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Zealot
    Join Date
    May 2013
    Posts
    128
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    images change(i mean working without problems) in Firefox and all others, but in Chro

    polisphotos.com/store/
    side bars (left & write) images change(i mean working without problems) in Firefox and all others, but in Chrome no, well?

    Code:
    ....head...
    <?php 
    header("Cache-Control: no-cache, must-revalidate");
    //  require_once("introPage.php");
    session_start(); 
        include("x/x.php");
    	$linkid = mysql_connect($hostname,$username,$password);
    	@mysql_select_db($database) or die( "Unable to select database");  
    
    	$query01 = "select p.* from P p join S s on p.Product_ID = s.Product_ID AND p.Visibility=1 order by s.AA;";   
    	
    	$result01 = @mysql_query($query01,$linkid);
    	$count01 = @mysql_num_rows($result01);
        
        if(!isset($_SESSION['off'])) ($_SESSION['off']=0);
      
    	$startrow1=$_SESSION['off']+4;//4
    	$endrow1=$_SESSION['off']+8;//8
    	$startrow2=$_SESSION['off'];
    	$endrow2=$_SESSION['off']+4;
    
    	$_SESSION['off']=$_SESSION['off']+8; 
        
    	if ($count01<$_SESSION['off']) {
        $_SESSION['off']=0;
        } 
    ?>
    ..............
    ....left side....
    <?php   
    		$i=0;
    		if ($count01 > 0) {
                 for ($i=$startrow1; $i<$endrow1; $i++) {
                 if ($i>=$count01) break;
    			    $Product_ID = mysql_result($result01,$i,"Product_ID");
    				$Category_ID = mysql_result($result01,$i,"Category_ID");
    				$Product_Description = mysql_result($result01,$i,"Product_Description");
    				$fileNameS = mysql_result($result01,$i,"fileNameS");
    echo "<p align='center'>"; 
    echo "<a href='image.php?recNo=".$Product_ID."&cat=".$Category_ID."&start=0'><img alt='left side featured photo' title='".$Product_Description."' src='images/".$Category_ID."/".$fileNameS."' /></a><br />PID: ".$Product_ID."<br /></p>"; 
    }
    		}
    ?>

  2. #2
    SitePoint Zealot
    Join Date
    May 2013
    Posts
    128
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    please check in your Chrome browser and tell if side columns images change on page change?

  3. #3
    SitePoint Enthusiast
    Join Date
    Mar 2010
    Location
    Surrey, UK
    Posts
    81
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Looks OK to me. If I reload the page in either Firefox or Chrome the images change. I'd suggest inspecting the source of the 'broken' page to see if the image URLs are changing and go from there.
    Martin.

  4. #4
    SitePoint Zealot
    Join Date
    May 2013
    Posts
    128
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    actually has a bug and used for debugging ... chrome and dw cs6... what ver of chrome you used? I use Version 27.0.1453.116 m... but have 18 tabs open... may this fault? any way check but keep tabs?

  5. #5
    SitePoint Enthusiast
    Join Date
    Mar 2010
    Location
    Surrey, UK
    Posts
    81
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm using the same version of Chrome, but I don't think it's a Chrome bug, nor do I think it's to do with how many tabs you have open. I wonder if the page is being cached and not refreshing for some reason. Try holding down shift and clicking reload to see if that makes any difference.
    Martin.

  6. #6
    SitePoint Zealot
    Join Date
    May 2013
    Posts
    128
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    again only in chrome problem. i will try chrome in my xp laptop soon. in the mentioned problem if continuously press the home button (left side bar-top) 3 times then images get change...only by this. as said i will try in my laptop...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •