SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Member dj4389's Avatar
    Join Date
    Apr 2003
    Location
    Kent, UK
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    help needed logging on to my forum

    I need some help urgently.

    I have posted a message here recently, but seems to have slipped down unnoticed. See: http://www.sitepointforums.com/showt...hreadid=113684

    To recap, neither myself or my 500+ members cannot login to my forum. When they try, they get the error message:"phpBB : Critical Error "

    "Error updating last visit time : session_begin "

    As suggested on the other thread, I open MyAdmin and click on the SQL tab and add REPAIR TABLE site name, which I had done. I then got an error message to say that the table doesnt exist.

    When trying to query without using the site name I got this error: SQL-query :
    REPAIR TABLE
    MySQL said:

    You have an error in your SQL syntax near '' at line 1

    I am getting desparate and at my wits end, and don't know how to solve the problem.

    PLEASE HELP .[img]images/smilies/smile.gif[/img]

  2. #2
    This is all Mumbo Jumbo Amit's Avatar
    Join Date
    Oct 2001
    Location
    New Delhi, India
    Posts
    277
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You have to enter like this.

    REPAIR TABLE tablename

    e.g. REPAIR TABLE users

  3. #3
    SitePoint Member dj4389's Avatar
    Join Date
    Apr 2003
    Location
    Kent, UK
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thank you for replying Amit.

    After entering REPAIR TABLE table name all the tables are read only.So what do I do next, as I'm a newbie to databases/MYSQL

  4. #4
    + platinum's Avatar
    Join Date
    Jun 2001
    Location
    Adelaide, Australia
    Posts
    6,441
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    on your sessions table, click empty (might want to back it up beforehand to be sure).

  5. #5
    SitePoint Addict sojomy's Avatar
    Join Date
    Jul 2002
    Location
    Dallas, TX
    Posts
    349
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by dj4389
    I need some help urgently.

    I have posted a message here recently, but seems to have slipped down unnoticed. See: http://www.sitepointforums.com/showt...hreadid=113684

    To recap, neither myself or my 500+ members cannot login to my forum. When they try, they get the error message:"phpBB : Critical Error "
    I realize that this problem may be frustrating, but do you really need to start 3 seperate threads about it? You started two identical threads, and were receving help in one as recently as this morning, why did you start a new thread?

  6. #6
    This is all Mumbo Jumbo Amit's Avatar
    Join Date
    Oct 2001
    Location
    New Delhi, India
    Posts
    277
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well in that case ...

    Close down your forums offically (for few hours) if it is not already down.

    Use a MySQL client like phpMyAdmin or MySQL-Front and make copies of all your tables. E.g. Copy users table as users2 and so on. Copy both the structure and the data!

    After all the tables have been copied, rename the old tables as table_old. E.g rename users as users_old and rename users2 as users. Do this for every table.

    Start the forum and see if everything works.

    If it works fine, download the old forums for backup and then delete them.

    HTH!

  7. #7
    SitePoint Member dj4389's Avatar
    Join Date
    Apr 2003
    Location
    Kent, UK
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Just to let you know, this morrning (Monday), I logged onto my forum to find it up and running again. It appears that my isp database was down and didnt notify me. I think that sucks.

    I will take you up on that good tip about making copies of the database, Amit.

    Thank you all who posted. I apologise for posting three times, I was just desparate to get the forum up and running having the members on my back, and not too sure how often people replied. I was also hoping that the Forum moderator would have deleted one of the duplicate threads. In future I will be more patient and only put up one posting.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •