SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Evangelist
    Join Date
    Jan 2002
    Posts
    457
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Need help with 3 columns

    I would like to create 3 columns on one of my pages. The three columns should be in addition to the navbar. (They should be contained inside the content div). I am using the float method to acheive this, but I must not be implementing it correctly because everything shows inside one column. The page should look like this.

    Mark-Up and Styles fixed.

    Thanks!
    Last edited by Joshua Clinard; Jun 30, 2003 at 13:56.

  2. #2
    SitePoint Enthusiast
    Join Date
    Oct 2002
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Add this to your .css file:

    Code:
    #petleft {
     width: 33%;
     float: left;
    }
    #petcenter {
     width: 33%;
     float: left;
    }
    #petright {
     width: 33%;
     float: left;
    }
    That should do it

  3. #3
    SitePoint Evangelist
    Join Date
    Jan 2002
    Posts
    457
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmmm...Sorry, that didn't do a thing.

  4. #4
    Your Lord and Master, Foamy gold trophy Hierophant's Avatar
    Join Date
    Aug 1999
    Location
    Lancaster, Ca. USA
    Posts
    12,305
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Look at this page:
    http://www.realworldstyle.com/nn4_3col_header.html

    Viewing the code will show how it is done.
    Wayne Luke
    ------------


  5. #5
    SitePoint Enthusiast
    Join Date
    Oct 2002
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmm. I downloaded your HTML and CSS file, added those lines to the CSS file, and it worked... strange.

    What browser are you using?

    Peter

  6. #6
    SitePoint Evangelist
    Join Date
    Jan 2002
    Posts
    457
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It turns out on my local machine, I had the file pointing to the wrong version of the stylesheet. Everything works as intended now. Thanks for the help.

  7. #7
    SitePoint Enthusiast
    Join Date
    Oct 2002
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Glad I could help


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •