SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Wizard
    Join Date
    Nov 2000
    Location
    Chico, Ca
    Posts
    1,125
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CSS Menu Errors in IE and Opera

    I have the site working perfectly in Mozilla (Firebird/Phoenix). But when I view it in IE (no suprise) and Opera the navigation is messed up. Anyone have any idea's?

    here is the link:
    http://www.cconway.com/5/

    any help would be apreicated,

    Chuck
    "Happiness doesn't find you, you find happiness" -- Unknown
    www.chuckknows.com

  2. #2
    SitePoint Member byss's Avatar
    Join Date
    Sep 2002
    Location
    Central Kentucky, USA
    Posts
    23
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You can try using line-height on your <li> elements to force IE, Opera, etc to use a specific height (and thus no gaps). Just fiddle around with how many pixels high (start around 18-20 and go from there) you need to make each element.

    Code:
    line-height: #px;
    Caution: Slow Children At Play -->

  3. #3
    SitePoint Wizard
    Join Date
    Nov 2000
    Location
    Chico, Ca
    Posts
    1,125
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hmm.. didn't think about doing that .. I'll try it out!

    Thanx

    Chuck
    "Happiness doesn't find you, you find happiness" -- Unknown
    www.chuckknows.com

  4. #4
    SitePoint Wizard
    Join Date
    Nov 2000
    Location
    Chico, Ca
    Posts
    1,125
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    For all those who have been waiting in suspense about my problem I have solved it! It turned out that I was using <li> with out the parent tag. That was throwing it off in Opera and IE.
    "Happiness doesn't find you, you find happiness" -- Unknown
    www.chuckknows.com


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •