SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Feb 2003
    Location
    Northern Ireland
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Script error...?

    Hi

    Can anyone shed some light on this problem for me. I'm in the process of putting a small site together and have included preloaders on each page for slower connections but for some reason the preloader stops at 99% and i get a message saying "A script in this movie is causing Macromedia Flash Player 6 to run slowly. Do you want to abort the script".

    The problem can be viewed here www.whitelinemultimedia.com

    My knowledge of debugging etc is minimal to say the least though when i ran the debugger it didnt produce any errors. The movie was exported for version 5 although i have version 6 installed. Also i published it useing Flash to generate the html if that makes any difference. I can produce the source files if required. Sorry if the information is a bit vague.

    PS. None of the links are active as yet as the page is still in development.

    Thanx...

  2. #2
    SitePoint Zealot webQS's Avatar
    Join Date
    Oct 2002
    Location
    Sydney : Australia
    Posts
    144
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi

    Sounds like the Flash Player has detected an infinite loop. Do you have any frame loops, while or for loops in the movie? Make sure these are working - I get the same thing when I stuff up a loop sometimes.

    Flash Player will stop if it detects something like this - to stop crashing the system. It's not anything to do with the markup provided as default by MM - although that is pretty shoddy.

    Cheers, hth
    James

  3. #3
    SitePoint Enthusiast
    Join Date
    Feb 2003
    Location
    Northern Ireland
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Cheers for the reply. I will have another look at it at the weekend and hopefully discover what the problem is. The guy im doing it for hasn't given me all the data yet so theres no immediate rush. In the mean time i have just done away with the preloader for that page.

    Thanx again


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •