SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    Patience... bronze trophy solidcodes's Avatar
    Join Date
    Jul 2006
    Location
    Philippines
    Posts
    936
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Can you see any error of this page?

    Hi guys,

    I just want to be sure.
    I already used FireBug to check it it has error but it says nothing.

    By the way the page is this,
    http://coder9.com/jazportfolio/admin/admin2/add_record

    What can you say, Do yo see any error like JavaScript or jQuery error?

    Thank you very much in advanced.
    Quality codes are optimized and tested...
    Click here for inspiration..

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,198
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    Firebug doesn't show any errors for me. Can you say a bit more about what the problem is? Is something not working?

  3. #3
    Patience... bronze trophy solidcodes's Avatar
    Join Date
    Jul 2006
    Location
    Philippines
    Posts
    936
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    @ralph.m

    Thank you for your reply.
    As you can see at the bottom of the page there is the save button and above it is the attach photo file button.
    When you attach a file it will save properly including it's data into Database properly.

    Now the problem occur If I press the save button without attaching a photo file.
    Sometimes the data is save properly and sometimes it doesn't.

    So I'm guessing this is a JavaScript of jQuery issue.

    By the way If you want to test it you can do like this,
    Step 1. Fill up the "Title" field (required)
    Step 2. Fill up the "Title url" field (required)
    Step 3. Fill up the "Description" (required)

    The rest are optional...
    Then you can opt to attach or not to attach a photo.
    Finally press the "save" button.

    The result will show up on this page,
    http://coder9.com/jazportfolio/

    Anyway I found one error using FireFox Web Tool
    Code:
    [09:00:49.321] Empty string passed to getElementById(). @ http://coder9.com/jazportfolio/js/jquery-1.10.1.js:174
    But I don't know how to fix that error.
    Can someone please give shed.

    Thank you very much in advanced.
    Quality codes are optimized and tested...
    Click here for inspiration..

  4. #4
    Patience... bronze trophy solidcodes's Avatar
    Join Date
    Jul 2006
    Location
    Philippines
    Posts
    936
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    When I used Chrome,
    The problem with chrome is when I don't attached a photo file for upload the data is not saved.
    But when I attached a photo file for upload it works fine.

    When I used MSIE,
    The problem with MSIE is when I attached a photo file the photo is not uploaded only the data.


    So my conclusion now is the "Photo File Upload" script is not cross browser and is the culprit.
    By the way I got the "Photo file upload" script from this site,
    http://www.saaraan.com/2012/05/ajax-...jquery-and-php
    Quality codes are optimized and tested...
    Click here for inspiration..

  5. #5
    Patience... bronze trophy solidcodes's Avatar
    Join Date
    Jul 2006
    Location
    Philippines
    Posts
    936
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Can you guys recommend a free "Photo File Upload" script/plugin with progress bar.
    That can run properly under bootstrap.

    Thank you very much in advanced.
    Quality codes are optimized and tested...
    Click here for inspiration..


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •