Hi guys, my xampp has been useless for weeks & You have always led me
back on the path & I thank you in advance. I was determined to conquer this own but all this trial error & reading hundreds of posts I haven't
quite made it.
========================================================
here is the message at the bottom of the control panel
before startup of the server:

8:23:18 PM [main] Initializing Control Panel
8:23:18 PM [main] Windows Version: Windows 7 Ultimate SP1 64-bit
8:23:18 PM [main] XAMPP Version: 1.8.1
8:23:18 PM [main] Control Panel Version: 3.1.0 Beta 6 [ Compiled: September 20th 2012 ]
8:23:18 PM [main] Running with Administrator rights - good!
8:23:18 PM [main] XAMPP Installation Directory: "c:\xampp\"
8:23:18 PM [main] Checking for prerequisites
8:23:19 PM [main] All prerequisites found
8:23:19 PM [main] Initializing Modules
8:23:19 PM [main] Starting Check-Timer
8:23:19 PM [main] Control Panel Ready
===================================================================
here is the error log:

Digest: generating secret for digest authentication ...
[Sat Apr 13 19:11:29 2013] [notice] Digest: done
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Child process is running
Sat Apr 13 19:11:30 2013] [notice] Child 5740: Acquired the start mutex.
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Starting 150 worker threads.
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Starting thread to listen on port 443.
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Starting thread to listen on port 80.
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Starting thread to listen on port 443.
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Starting thread to listen on port 80.
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
==================================================================
and this display when I click on the services. mysql stays on and apache
shuts off immediatey:

8:28:56 PM [main] Initializing Control Panel
8:28:56 PM [main] Windows Version: Windows 7 Ultimate SP1 64-bit
8:28:56 PM [main] XAMPP Version: 1.8.1
8:28:56 PM [main] Control Panel Version: 3.1.0 Beta 6 [ Compiled: September 20th 2012 ]
8:28:56 PM [main] Running with Administrator rights - good!
8:28:56 PM [main] XAMPP Installation Directory: "c:\xampp\"
8:28:56 PM [main] Checking for prerequisites
8:28:56 PM [main] All prerequisites found
8:28:56 PM [main] Initializing Modules
8:28:56 PM [main] Starting Check-Timer
8:28:56 PM [main] Control Panel Ready
8:29:23 PM [Apache] Attempting to start Apache app...
8:29:24 PM [Apache] Status change detected: running
8:29:24 PM [mysql] Attempting to start MySQL app...
8:29:25 PM [mysql] Status change detected: running
8:29:27 PM [Apache] Status change detected: stopped
8:29:27 PM [Apache] Error: Apache shutdown unexpectedly.
8:29:27 PM [Apache] This may be due to a blocked port, missing dependencies,
8:29:27 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:29:27 PM [Apache] Check the "/xampp/apache/logs/error.log" file
8:29:27 PM [Apache] and the Windows Event Viewer for more clues