SitePoint Sponsor

User Tag List

Results 1 to 9 of 9
  1. #1
    SitePoint Zealot
    Join Date
    Aug 2000
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can anyone help me out connecting PHP to a MSSQL database, as I'm pulling my hair out (and I haven't got a lot to start with)

    I keep getting the message "Call to undefined function: mssql_connect()" on my PHP pages. I've tried all the suggestions on php.net regarding the php.ini and it still doesn't work.

    The database is in SQL Server 6.5 and I'm running IIS 4.

    Thanks for any suggestions.

  2. #2
    Dumb PHP codin' cat
    Join Date
    Aug 2000
    Location
    San Diego, CA
    Posts
    5,460
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I will get the easy ones out of the way first. You are sure that the php_mssql65.dll lives in your extensions directory for PHP. and you have the appropriate line uncommented in your php.ini file.
    Specifically:
    extension=php_mssql65.dll


    If you do not have this file, give me your email address and I will send it to you
    Please don't PM me with questions.
    Use the forums, that is what they are here for.

  3. #3
    SitePoint Zealot
    Join Date
    Aug 2000
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yep, the files definately there. In fact I know that it's picking up the file because if I put "extension=php_mssql65.dll " in the ini file twice and stop and restart the IIS services it comes up with a load of duplicate command error messages.





  4. #4
    Dumb PHP codin' cat
    Join Date
    Aug 2000
    Location
    San Diego, CA
    Posts
    5,460
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What email can I send you a file at, I have one that can tellyo uexactly what extensaions are running and what functions are available to each
    Please don't PM me with questions.
    Use the forums, that is what they are here for.

  5. #5
    SitePoint Zealot
    Join Date
    Aug 2000
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You can send me an email at steve@gelf.dircon.co.uk. I can run it tomorrow when I'm back in work. (I'm in the UK)

    Thanks for the help by the way.

  6. #6
    SitePoint Zealot
    Join Date
    Aug 2000
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    OK, I ran the file and the module is definately not loading. I actually managed to connect to the server today using ODBC instead. I would still like to get the mssql working as well though.

  7. #7
    Dumb PHP codin' cat
    Join Date
    Aug 2000
    Location
    San Diego, CA
    Posts
    5,460
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You should try and get another copy of the extension try http://www.php4win.de
    Please don't PM me with questions.
    Use the forums, that is what they are here for.

  8. #8
    SitePoint Zealot
    Join Date
    Aug 2000
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks,

    I'll give it a try.

  9. #9
    SitePoint Zealot
    Join Date
    Aug 2000
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've tried four different versions of the extension now and it still doesn't work. I've even tried setting it up on a different IIS server with no joy. There must be something obvious that I'm missing.

    It's strange because it still reports the duplicate command messages if I put the "extension=" line in the INI file twice.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •