SitePoint Sponsor

User Tag List

Results 1 to 14 of 14
  1. #1
    SitePoint Addict
    Join Date
    Feb 2013
    Posts
    243
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Want to get away from pixelated/choppy fonts!

    Im currently using a full hd 15" asus g53sx laptop, and my problem is that i loose movitation because how much i end up tweaking font weights and sizes the fonts always seem to end up a bit pixelated or choppy... the only time they seem to look good is when they are really big... like 4+ em in size.

    Maby i am to much of a perfectionist, and the text on my screen looks exactly like on everyone else's.

    Is getting a laptop with a high res sceen like a macbook retina my only option? Im looking for the kind of pixelperfection u see on tablets etc...

    EDIT: maby wrong part of the forum, if so feel free to move the thread mr.moderator.

  2. #2
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,222
    Mentioned
    51 Post(s)
    Tagged
    2 Thread(s)
    Post a link so we can see these pixelated choppy fonts, too.

  3. #3
    SitePoint Addict
    Join Date
    Feb 2013
    Posts
    243
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ronpat View Post
    Post a link so we can see these pixelated choppy fonts, too.
    Its not only on my sites, i experience this on most sites i visit. Take this one for example... a really nice site.. except that all the headings with the big and thin proxima nova fonts look pixelated and ugly on my screen. http://www.madebyhangar.com/

  4. #4
    SitePoint Enthusiast
    Join Date
    Aug 2011
    Posts
    85
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    ReGGaeBOSS, either you have super eagle eyes, or there's something wrong with your browser - that font looks fine on that site.

  5. #5
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,222
    Mentioned
    51 Post(s)
    Tagged
    2 Thread(s)
    Quote Originally Posted by ReGGaeBOSS View Post
    Its not only on my sites, i experience this on most sites i visit. Take this one for example... a really nice site.. except that all the headings with the big and thin proxima nova fonts look pixelated and ugly on my screen. http://www.madebyhangar.com/
    You wrote about this issue in a previous post. I suggested that you check your computer's system settings and provided "how-to" instructions. You never responded. Did you try that? It DOES make a difference.

    http://www.sitepoint.com/forums/show...=1#post5444434

  6. #6
    SitePoint Addict
    Join Date
    Feb 2013
    Posts
    243
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ronpat View Post
    You wrote about this issue in a previous post. I suggested that you check your computer's system settings and provided "how-to" instructions. You never responded. Did you try that? It DOES make a difference.
    oh forgot about my other thread. Is it the cleartype settings u are talking about? if so yes i have checked cleartype etc, but no real difference. Il check my old thread to see exactly what u wrote.

  7. #7
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,222
    Mentioned
    51 Post(s)
    Tagged
    2 Thread(s)
    Would you mind posting a screenshot of the pixelated display on your browser? I'm really curious about this issue.

  8. #8
    SitePoint Addict
    Join Date
    Feb 2013
    Posts
    243
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ronpat View Post
    Would you mind posting a screenshot of the pixelated display on your browser? I'm really curious about this issue.


    Maby it doesnt look to bad in your eyes but imo it looks pretty bad, maby im just to picky and used to the nice pixels on my full hd 10" tablet. This is just a random example of how most text that isnt 3.5+ em in size look on my display. As u can see the text look pixelated and choppy. It looks worse "irl" tho then on the picture.

  9. #9
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,222
    Mentioned
    51 Post(s)
    Tagged
    2 Thread(s)
    Thoughts: This looks and sounds like a system problem.

    (1) Can I assume that the ClearType software is enabled in your Asus laptop? It looks like it is enabled.

    (2) What browser are you using?

    (3) Are you zooming either text or images and text larger than "normal"? If so, how much?

    (4) You mentioned fonts that are set to 3.5em or larger being reasonably OK, so are you zooming the text in your browser to achieve that size? Where did you come up with that number? Just a way of describing "about how big"?

    (5) 3.5em is quite massive. It suggests that your video card is set to a value that is less than your screen density (dpi). What is the dpi setting of your video card?

    (6) If 96dpi or so, it probably should be much higher. It should at least match the dpi of the screen so the images and text are rendered at a "normal" size before zooming. It can be greater than than the dpi of the screen, but should not be less than.
    For example, some video cards are optimized to scale very well at certain (common) screen densities, but become a little jagged at other densities. You'll have to see what densities your card is optimized for.

    (7) Have you tweaked the setting of the video card since the computer was new? Maybe I should ask if you bought it new.

    If all else fails, I would recommend returning to basic sytem defaults and reevaluating how fonts render. Something looks out of kilter and (at the risk of stereotyping) gamers are notorious tweakers .


    This is not a CSS problem. The moddies might want to move this thread to a more appropriate forum as I believe this is a hardware/system issue.

  10. #10
    SitePoint Addict
    Join Date
    Feb 2013
    Posts
    243
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ronpat View Post
    Thoughts: This looks and sounds like a system problem.

    (1) Can I assume that the ClearType software is enabled in your Asus laptop? It looks like it is enabled.

    (2) What browser are you using?

    (3) Are you zooming either text or images and text larger than "normal"? If so, how much?

    (4) You mentioned fonts that are set to 3.5em or larger being reasonably OK, so are you zooming the text in your browser to achieve that size? Where did you come up with that number? Just a way of describing "about how big"?

    (5) 3.5em is quite massive. It suggests that your video card is set to a value that is less than your screen density (dpi). What is the dpi setting of your video card?

    (6) If 96dpi or so, it probably should be much higher. It should at least match the dpi of the screen so the images and text are rendered at a "normal" size before zooming. It can be greater than than the dpi of the screen, but should not be less than.
    For example, some video cards are optimized to scale very well at certain (common) screen densities, but become a little jagged at other densities. You'll have to see what densities your card is optimized for.

    (7) Have you tweaked the setting of the video card since the computer was new? Maybe I should ask if you bought it new.

    If all else fails, I would recommend returning to basic sytem defaults and reevaluating how fonts render. Something looks out of kilter and (at the risk of stereotyping) gamers are notorious tweakers .


    This is not a CSS problem. The moddies might want to move this thread to a more appropriate forum as I believe this is a hardware/system issue.
    So it isnt just me then?=)

    1. Yes cleartype is enabled.

    2. chrome and firefox.

    3. no my browser size is set at 100%.

    4. thats just a way to describe "about how big", for example i was doing a heading for a website the other day and it absolutely looked like **** in my prefered size which was 2.5 em, but at 3.5 and up it looked good and smooth.

    5. going to check the video card, not sure how to check this tho so il have to google it:P

    6.

    7. hmm done some minor tweaking.

    I will get back as soon as i have checked my videocard settings.

    thanks

  11. #11
    SitePoint Addict
    Join Date
    Feb 2013
    Posts
    243
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Changed my videocard settings to factory defaults now... they where set for performance, and are now set to quality. Can't say i see any difference tho. SOMETHING is different... but not the fonts.

  12. #12
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,222
    Mentioned
    51 Post(s)
    Tagged
    2 Thread(s)
    Guess it's good that there was not a wager involved, 'cause I woulda lost the bet.

    Is there any common thread to the "ugly" fonts? Are they always non-Microsoft fonts?, are they served with @font-face?, etc.

    I'm still leaning toward hardware, drivers, or system, and was betting that restoring the video card to its default settings would have fixed everything. That leaves the video driver as a possibility.

    I will do some googling and reading and see if I can find anything. Don't wait up. This may take some time.

    If you find the answer first, please be sure to post it!

  13. #13
    SitePoint Addict
    Join Date
    Feb 2013
    Posts
    243
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ronpat View Post
    Guess it's good that there was not a wager involved, 'cause I woulda lost the bet.

    Is there any common thread to the "ugly" fonts? Are they always non-Microsoft fonts?, are they served with @font-face?, etc.

    I'm still leaning toward hardware, drivers, or system, and was betting that restoring the video card to its default settings would have fixed everything. That leaves the video driver as a possibility.

    I will do some googling and reading and see if I can find anything. Don't wait up. This may take some time.

    If you find the answer first, please be sure to post it!
    thanks for taking the time to help! i too will continue the investigation:P

    Its not good for the motivation when developing sites... ATM im writing the code, uploading the site when i do changes, and check the results on my tablet to get the "aah yes that looks good" feeling.

  14. #14
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,222
    Mentioned
    51 Post(s)
    Tagged
    2 Thread(s)
    From the previous thread, you say that you are using GoogleFonts and TypeKit fonts on your site. What about the other sites that you've visited whose fonts also render pixelated on your PC... are they also using GoogleFonts or TypeFace fonts or another @fontface font? We are aware that Cufon had some problems with their fonts that seems to have been remedied by their new drivers, so maybe this is a case where GoogleFonts and/or TypeFace fonts are not rendering properly on your PC for some reason. In searching for common threads, we should consider that possibility.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •