SitePoint Sponsor

User Tag List

Results 1 to 6 of 6

Thread: gotoAndPlay?

  1. #1
    SitePoint Member
    Join Date
    May 2003
    Location
    America
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry gotoAndPlay?

    Hi.

    I have a problem with my interface.

    In the opening Scene, I have a movie clip with buttons in it. These buttons are supposed to let me jump to different scenes.

    The actions applied to the buttons are something like this:

    on (release) {
    _root.gotoAndPlay ("2d","flat");
    }

    However, the button does nothing. At all.

    Could someone please help me in fixing this problem?

  2. #2
    SitePoint Member
    Join Date
    May 2003
    Location
    USA
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by daheroes
    Hi.

    I have a problem with my interface.

    In the opening Scene, I have a movie clip with buttons in it. These buttons are supposed to let me jump to different scenes.

    The actions applied to the buttons are something like this:

    on (release) {
    _root.gotoAndPlay ("2d","flat");
    }

    However, the button does nothing. At all.

    Could someone please help me in fixing this problem?

    Are you using the Scene really? or just to refering to your movie? I Scenes can get real tricky.
    on (release) }

    {

  3. #3
    SitePoint Wizard aaron.martone's Avatar
    Join Date
    Feb 2003
    Location
    Florida, USA
    Posts
    2,322
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Do you have a scene called "2d"?
    Does it have a frame in it called "flat"?
    Did you place that code ON the button as opposed to the frame?
    Does the button have that same functionality at the time in the timeline that it was pressed?
    Do you like Rice Krispie Treats?

  4. #4
    SitePoint Enthusiast RelandR's Avatar
    Join Date
    May 2003
    Location
    Sacramento, Ca.
    Posts
    61
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    scenes are evil...
    ...and frame labels aren't fully supported in all browsers on all machines,
    loading ext. swf's and playing clips works better...

    ...rice krispie treats are yummy

  5. #5
    SitePoint Member
    Join Date
    May 2003
    Location
    America
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    to aaron.martone:
    Yes to all of your questions.
    Especially the one about Rice Krispy Treats.

    However, I'm still lost. How would I go about using movie clips in this? I could see using them for this animation in particular, however i have another, in which the infinite menu i created doesn't work, and I tried both using MCs and scenes.

  6. #6
    SitePoint Member
    Join Date
    May 2003
    Location
    America
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    oh, if you don't know what an infinite menu is, it can be found here...

    http://www.kirupa.com/developer/mx/infinite.htm


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •