SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Addict Banana Man's Avatar
    Join Date
    Dec 2005
    Posts
    391
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    invalid get parameters in url

    I have noticed in Google analytics, page content url's with invalid GET parameters appearing. For example i see hits on a url of www.mysite.com/about/?parameter=example=param even though i dont not have any links to this url. This url displays as if the url was just set to www.mysite.com/about/. I dont know why or how people are accessing the page with such url's.

    In one section of my site i am using a .htaccess mod_rewrite where url's are supposed to be in this format but again i never actually link to any url's with this format, instead i use mod_rewrite to display such url's like www.mysite.com/about/example-param. If i remove this condition from my .htaccess file this issue still arises anyway. Does anyone have any ideas why this might be happening? After testing it seems that any url will work if it ends in a ? no matter what i put after it. I could just check for any parameters in a url on pages where they should not be appearing and redirect to a 404 error but i would prefer to find out what is causing this issue in the first place.

    Thanks!

  2. #2
    SitePoint Member
    Join Date
    Sep 2007
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    There are many thing that can be causing that on your site. if you have a site with a form on the page and the method is get, Search engine in the process of indexing will execute the form, disable javascript and append those parameters to your url.
    Another option is if your site has a very high pagerank and your site return search result without formating it with php htmlentities, a spammer can query for their site url on your search and the result returned will contain their url in the body of your site as a html hyperlink, with this method he will submit your site with query parameter to search engine, and automatically linked to you.
    i will advice you change any form on your site that is using method get to post. but if these results are not appearing in your webmaster tool as error, don't bother your self


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •