SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Member
    Join Date
    May 2003
    Location
    California
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problems finding php.ini settings blocking this.

    So basically, the hosting company just got a new server, that means new php.ini settings. I'm trying to find the ones that may pertain to this not working..

    Error being:
    Warning: session_register() [function.session-register]: Cannot send session cache limiter - headers already sent (output started at /home/teamvin/public_html/auth_settings.inc.php:72) in /home/teamvin/public_html/auth.inc.php on line 115

    Warning: Cannot modify header information - headers already sent by (output started at /home/teamvin/public_html/auth_settings.inc.php:72) in /home/teamvin/public_html/auth.inc.php on line 117

    Yes, global_register is set to 1.

    home/teamvin/public_html/auth_settings.inc.php:72 (line is actually after the php ending, so heres it all)
    PHP Code:
    <?
    $redir
    ="auth.php";
    $pwzunvalid="Not logged in";
    $pwzvalid="Logged in as ";
    $pwzcookie="vind_auth";
    $pwzsql['host']="localhost";
    $pwzsql['user']="****";
    $pwzsql['pass']="****";
    $pwzsql['db']="****";
    $pwzsql['table']="****";
    $pwzdebug=1;
    $pwzrefer="log.dat";
    $pwztomaj=0;
    ?>
    -errored here-
    /home/teamvin/public_html/auth.inc.php on line 115
    PHP Code:
            session_register("pwzmsg"); 
    /home/teamvin/public_html/auth.inc.php on line 117
    PHP Code:
            Header ("Location: $redir"); 
    Thanks for all help, appreciative.

    (If you need me to paste more code, let me know)

  2. #2
    SitePoint Member
    Join Date
    May 2003
    Location
    Newcastle
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    All function which send out HTTP headers (including session_register and header) need to come before anything is sent to the browser.

    Your problem is usually caused by some whitespace, a blank line somewhere.. looks like it's at the bottom of your auth_settings.inc.php file. You need to make sure there are no blank lines before the <? and none after the ?>

  3. #3
    SitePoint Member
    Join Date
    May 2003
    Location
    California
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Funny thing was, on the last server before the change-over, everything worked fine. Same pages, nothing has changed. So out of guessing, thought it would have to deal with php.ini settings.

    Will try, though.

    Thanks.

  4. #4
    SitePoint Member
    Join Date
    May 2003
    Location
    California
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Also, this is the page to which this all connects to:

    http://www.teamvindicate.com/auth.php

    Now that I have taken out all whitespaces, won't even load :O

  5. #5
    SitePoint Member
    Join Date
    May 2003
    Location
    Newcastle
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well at least the first error was fixed

    Your header() in auth.php is sending the browser back to auth.php, so it's just a loop.

  6. #6
    SitePoint Member
    Join Date
    May 2003
    Location
    California
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hrm, I'm not seeing this in the source itself, well, here's the page in phps:

    http://www.teamvindicate.com/auth.phps

    Thanks again.

  7. #7
    SitePoint Member
    Join Date
    May 2003
    Location
    Newcastle
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It's a combination of this from auth_settings.inc.php

    PHP Code:
    $redir="auth.php"
    and this from auth.inc.php

    PHP Code:
    Header ("Location: $redir); 
    So when you visit auth.php it require()s auth.inc.php, and you're sent a "Location: auth.php".


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •