SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast daliren's Avatar
    Join Date
    Oct 2001
    Posts
    68
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    GRANT command ineffective on 3.23.56

    I just installed v3.23.56 and set up a database which has the same security settings as the remote one I cloned it from. I set up a user in mysql.user with the appropriate password, but when I try to use GRANT to establish priviledges, I always get the message:

    Query OK, 0 rows affected

    meaning, of course, that nothing happened. I wrote the GRANT statement as follows:

    mysql> grant select, insert, update, delete
    -> on xxxdb.*
    -> to xxxuser@localhost;

    This is supposed to work, but no. I tried leaving off the "@localhost" and got the same result. I even tried to update mysql.user to change the "N"s to "Y"s in each priviledge colum, which also returns "Query OK, 0 rows affected."

    Is this some sort of bug or does something need to be unlocked that I don't know about?
    cheers,

    Darren Cassidy

  2. #2
    SitePoint Addict
    Join Date
    Mar 2002
    Posts
    327
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Which Operating System are you using? If Linux, are you logged in as root?

    Nick
    All4YourPC for all your PC needs. Custom software.
    Websites. Web marketing. Training.
    http://members.aol.com/nickjc67


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •