SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Enthusiast blakems's Avatar
    Join Date
    Oct 2002
    Location
    Utah
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    background image in body.

    I have a background image being repeated however. the mozilla is adding pixels to the top of the margin. see image below.



    Anyone have ideas how to get around those extra 5 px or why it is doing it?
    here is the css for it

    background: #DBE2F2 url(/i/topBg.gif) repeat-x top left;
    blakems.com
    "reaching more of your brain cells"


  2. #2
    SitePoint Evangelist Alexandra's Avatar
    Join Date
    Aug 2002
    Location
    Perth, Australia
    Posts
    414
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    blakems,

    Have you tried setting the page's margins to 0 either through CSS or the BODY tag?

    I have found that you need to set it in "old HTML" style to make sure the margins truly are 0 in Netscape, particlularly in the 4 series browsers.
    Alex Graham
    Cadmium Design & Development
    www.cadmium.com.au
    alexandra@cadmium.com.au

  3. #3
    gingham dress, army boots... silver trophy redux's Avatar
    Join Date
    Apr 2002
    Location
    Salford / Manchester / UK
    Posts
    4,838
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    could we see your full code + css ?

    and alexandra: fwiw, it's ONLY netscape 4.x that needs the "old HTML" style. setting margin: 0 and padding: 0 in the body css will work in all versions > 4.x (and with the padding 0 it will even work correctly in Opera, which up to now had been my main gripe)
    re·dux (adj.): brought back; returned. used postpositively
    [latin : re-, re- + dux, leader; see duke.]
    WaSP Accessibility Task Force Member
    splintered.co.uk | photographia.co.uk | redux.deviantart.com

  4. #4
    SitePoint Enthusiast blakems's Avatar
    Join Date
    Oct 2002
    Location
    Utah
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I guess no one knows the solution to this. I have set the margin and padding to 0. It is a weird bug
    blakems.com
    "reaching more of your brain cells"


  5. #5
    SitePoint Enthusiast blakems's Avatar
    Join Date
    Oct 2002
    Location
    Utah
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Here is the full css for it

    html, body {
    background: #DBE2F2 url(/i/topBg.gif) repeat-x top left;
    margin: 0;
    padding: 0;
    font: normal 12px Arial, Helvetica, sans-serif;
    }
    blakems.com
    "reaching more of your brain cells"


  6. #6
    SitePoint Enthusiast blakems's Avatar
    Join Date
    Oct 2002
    Location
    Utah
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I actually found the error. I just removed the html selector and that corrected it.

    Thanks anyway
    blakems.com
    "reaching more of your brain cells"



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •